TaskPaper 3.5 Preview (236)

The spelling of “pallet” threw me - isn’t it generally “Palette” in a UI context?
Example: https://developer.apple.com/library/prerelease/content/documentation/DeveloperTools/Conceptual/InstrumentsUserGuide/WorkingwithIndividualInstruments.html

(Pallet = crude bed or shipping platform; palette = artist’s color paint board; palate = the roof of your mouth.)

Fixed for next release:


1 Like

Definitely on my list, just not quite there yet.


I’ve got an idea, but please let me know if you figure out how to reproduce more exactly.

So your entire MacBook (all other applications too) experience this problem, or just TaskPaper?

OK, big mistake to lump all tags as searches. I used some tags as style for when I don’t want to have a heading show up on the sidebar (I style it similarly and put a style tag on it). The whole point of customizing the side bar with folding sidebar options was to - you know … customize it to user work flow.

Searches … are searches. They start with the word search and have a formula attached to them. They are defined as such. Yes, tags will also search and if you want that, you can also build a tag list. But searches and tags are- not - the - same.

Right now (pre-preview 3.5) I have searches at top and by arraigning them in the document they are exactly where I want to look for them. Then I have the rest of it.

I was really hoping for a more customization sidebar so that I could show what I wanted and hide what I wanted to hide.

Can’t this be made similar to Finder and how you can drag in what you are working on, add searches and move them around and delete items when you are through working on them? Who wants to see their whole hard drive on there finder sidebar? Who wants to see every aspect of every document on the sidebar all the time? I want to see just the bits I want to focus on. Customization is a very good thing for managing time for unmanageable people. :wink:

Also: None of my tag effects are showing up in preview 3.5. Was there a change made to the way To reads theme.less files?

Sorry to not have been more specific, but only in TaskPaper.

Is there any chance of changing the font size as well? Thx.

I have to roll back 3.3.2(219)!

#There’s some kind of input problems in 3.5 preview version.
(10.11.6 / MBP mid2010)

  • occasionally… no cursor, no input
  • the consonants and vowels separated
  • and Still remain input delay in Korean (esp Big file)

Will it also be possible to revalidate/reactivate a license for the preview if I bought TaskPaper 3 in Apple’s app store?

I’ve tried the print feature- thank you for this! What is the best way to adjust font size? The default is rather large.

I’m having the same issue. I press the return key, it advances to the next line, but I cannot input text. The up and down arrows work, as well as the enter key, but it won’t allow for text input. I have found that the only way to solve this is to quit TaskPaper and start again.

It only happens in TaskPaper.

Appears in Console as uncaught exception and: “_registerUndoObject:: BirchEditor. DisabledUndoManager 0x7f9ce164acc0 is in invalid state, must begin a group before registering undo”

Thanks, I think I’ve got a fix in the next release for this one.

You need to edit the theme file and modify the @user-font-size in the theme that you’ve chosen to print with. This is easy if you know how to edit themes, but painful if you don’t. I’ll look to add a simpler zoom in/out button in the print preview dialogue, hopefully for 3.5 release.

I certainly wouldn’t change this codebase back :slight_smile:

I like Swift (also using Objective-c runtime from Swift) better. There are certainly some headaches that come with swift related to complexity of type system combined with me not understanding how it all fits together exactly. But there are few really big wins that I wouldn’t want to leave behind:

  1. I don’t need to mange separate header files!
  2. I don’t need to manager importing individual files!
  3. Generally the syntax feels more like CoffeeScript (which I use for the JavaScript layer), even though the runtime is very different. Still nice to have similar syntax.

Thanks so much. I do know how to install themes, so until you offer this feature, I’m sure I’ll manage.

Is this problem temporary, or do you need a to restart TaskPaper to make it go away. I’m trying to figure out if is related to some underlying crash, or an input handling problem. If it’s related to underlying crash then might be better in yesterdays release (that fixed a number of crash problems). Anyway, thanks for help, and of course if you can figure out how to reproduce that helps even more.

Yesterday I saw an upgrade on the beta version. When I tried to download I got an Error message. Same thing again today. Was that version pulled? Or, is there a link to get it directly instead of going through the app?

I was glad to read in the notes that the tags are now being tried as a separate section in the sidebar. Looking forward to a more customizable sidebar experience.

Also looking forward to using customs font sizes and colors with my priority tags in the beta version again.