Possible to hide squiggly marks under curly quotes?

Sorry if this has been covered; couldn’t find anything. I always use smart quotes, curly quotes, whatever you want to call them, and I find the squiggly lines (don’t know the technical term) under them distracting. Is there a way to hide these, or not have them appear in the first place? Thanks!

I may be using different smart quotes but I guess this is what you are seeing underneath ?

(blue squiggly lines)

Screenshot 2023-01-17 at 19.07.09

( I’m only seeing them in whichever line has the selection, so the simplest way to hide them seems to be to move the cursor elsewhere )

@complexpoint Thanks, I expect those are the squiggles and you are also correct, best way to hide them right now is just move cursor to another sentence.

@npydyuan Those squiggles are showing to indicate that some text has been autocorrected, substituted, or replaced. Basically all those terms mean same thing… you typed something and then computer decided that it knew better and replaced what you typed with something else.

I feel like these cases are important to notice, so Bike shows that underline a bit longer than other apps do. Bike will show those squiggles for the current sentence that the text caret is in.

Later you I might offer a way to customize this, but for now I think the behavior is good. I guess now that you know the how and why and when they go away they might be less distracting. Hope so! Give it a try for a bit please and report back.

1 Like

I see what you’re saying, but I would still eventually prefer to be able to turn them off. I did notice that they appear only when cursor is in the current line, but nevertheless, they just bug me for some reason.

For you is the problem correction indicators in general, or only the smart quote substitutions?

Hmm, not sure—smart quotes is the only auto-correction I usually enable. I think I would have the same reaction to any of them, if I were to use the others. One thing I was thinking might be cool would be if they appeared, stayed visible while I was in that line, disappeared when I left that line, but then didn’t reappear again when I went back to that line later. Maybe that’s too complicated, though! If the only option besides the current behavior were to just turn the indicators off altogether, that’s what I would choose.

1 Like

I find the blue underlines really annoying. I get that they are there to show autocorrections but the net effect is that it is impossible to type certain words into Bike without activating the blue squiggles e.g. “doesn’t”. In other words, if I type in D-O-E-S-N-’ the T is added for me automatically and I get the blue squiggles.

I get that this is tied to the underlying OS behaviour to some extent but on the other hand it is literally impossible to type some correctly spelled words into Bike without blue squiggles, despite typing the correct sequence of characters. It also differs (in a bad way) from expectations of software on macOS

At the very least it feels like when the focus leaves the current line the fact that a word has been autocorrected should be forgotten. Almost every Bike outline I have has lines with blue squiggles, a huge distraction from the benefit of this app—a focus on a clean text-based outline.

Do you find it helps to uncheck the Show ... error checkboxes under

Edit > Checking > Show Checking


No, doesn’t help.

I have both “Show spelling errors” and “Show grammar errors” off.

Which makes sense because these aren’t actually errors—the spelling/grammar is correct.

To summarise my issue with this: with a default macOS configuration and a default Bike configuration my outlines are littered with squiggly blue lines despite me typing perfectly. These squiggles are unfixable unless you choose a different way to say something.

This feels all wrong to me and is unlike the behaviour of any other macOS app that I know of. It’s intrusive and distracting, the opposite of what I expect from Bike (which I love in pretty much every other respect).

Have you tried entering strings like doesn’t after switching off
Use smart quotes ?

Surely switching off smart quotes would make the squiggles go away but for me (not to answer for the other poster in this conversation, but I think we may be in agreement on this) that’s not a solution. I do want smart quotes but don’t want squiggles.

Heheh… “squiggles”… the more i type it, the funnier it sounds.

Turning off “Use smart quotes” does indeed fix the “doesn’t” problem for newly typed text, but anything previously entered remains underlined.

But the “doesn’t” example is just one example. Even with “Use smart quotes” turned off, any other auto-corrected word stays squiggly-underlined for ever, no? This goes strongly against the widely held principle of least surprise. No other macOs app behaves this way to my knowledge. I am all in favour of doing things differently where it makes sense but highlighting an autocorrection for so long doesn’t sit well with me at all.

Only, I think, in the line containing the cursor.

Indications of automatically modified text (and thus the possibility of automatic reversal) are displayed only in the active line.

Whenever we find them distracting, and want to hide them, we can move the cursor to an empty line.

I think the big difference is that Bike shows all the autocorrects in the current sentence, while most Mac editors only show autocorrect of the current word. I’ll think about options.

Thanks Jesse! I’m sure you’ll come up with the right compromise.

Responding to @complexpoint:

Whenever we find them distracting, and want to hide them, we can move the cursor to an empty line.

While that’s certainly true, for me it doesn’t work because I often unconsciously move the cursor to the line I’m reviewing and then—bam!—I’m reminded of the autocorrect again, which distracts from the job at at hand, which is reviewing the text.

To me Bike is all about focusing on the text. Anything as distracting as a squiggly underline really needs to justify its distracting effects to merit inclusion. For me, that the underline is the result of an autocorrect made at some point the past does not meet that bar, but perhaps I’m unusual :slight_smile:


@ronancremin completely agree.

Please try latest preview release:

I’ve changed behavior to only show replacement indicator:

  1. When selection is in corrected word
  2. For most recent correction right after it has been inserted