Link opening permissions for local file:// links

I’m finding (Bike 1.0 – 31 – Preview) that I can only follow local file:// links from Bike if the file is directly openable by the Bike.app itself (.bike, .opml) (but not .txt).

In the case of other extensions (.txt, .html, .gif etc etc) which from a link in TaskPaper would lead to a file opened in a relevant app, or shown in the Finder, I am getting an error message like:

2 Likes

Thanks, I think this should work in latest release.

1 Like

This is getting very promising in Preview 1.0 build 33.

One slight puzzle:

  • after drag and drop of a file to a Bike link, link-clicking works well,
  • but when I re-open a Bike file which already contains links, at first I still get a does not have permission to open message when file:// links are clicked.

Sometimes this clears after a while – I thought at first after an additional drag and drop to create a file link, but I’m still not quite sure what the pattern is …

intermittent


I think the pattern may be that:

  • File links created in the current editing session are consistently live
  • File links already in the Bike document when it is reopened are typically no longer live (lead to does not have permission messages)
  • where we have several links to the same file, existing dead links to a given file are all reanimated by the drag-and-drop creation of a new link to the same file.

In Console.app, things like:

default 21:07:45.048891+0000 kernel Sandbox: 3 duplicate reports for Bike deny(1) file-read-xattr /Users/houthakker/Desktop

Not sure if this is related, but sometimes the drag an drop of a file into a Bike document seems to freeze the app (perhaps particularly where there is already a (dead ?) link to the same file in the document ?)

The blue drag and drop cursor below has frozen while trying to drag in a new link to extensionInstalled.png from the macOS Desktop.

Grrr, it’s the macOS Sandbox causing problems. I guess Bike has temporary permission when you first drag url to app, but not on restart. Also links will work if you have the document that’s being linked to already open in Bike no matter the restart status.

I guess I will have to just reveal file links in Finder instead of open them directly. Reveal in Finder does seem to always work.

1 Like

Thanks – that sounds good – I find it quite a flexible way to work.