I am not getting checkboxes though it works properly


#1

When I type a - for a checkbox I get 'Hi instead. Otherwise the TP3 preview looks good.


Check marks where there should be checkboxes
Weird icons and broken indentation
#2

Do you have the font “Source Sans Pro” installed? … If you deactivate that on your Mac then does it work?


#3

After disabling Source Sans Pro in FontBook the Taskpaper task lines turn into incomprehensible characters and symbols. The project and notes lines are unaffected.


#4

Did you restart TaskPaper after disabling the font… anyway I guess I sorta know what the issue is now. TaskPaper embeds Source Sans Pro … but then that embedded version seems to conflict with user installed versions sometimes. I’m still not quite sure what the solutions is.


#5

Restarting Taskpaper works! Thanks Jesse. The preview seems to work well now. I may comment more later.


Bullet boxes are showing up incorrectly
#6

If you get a chance can you send me jesse@hogbaysoftware.com the regular variant of the version of Source Code Pro that you had installed? I just installed fresh from Google Fonts and can’t seem to recreate the problem, I think maybe it’s when there are two different versions of Source Code Pro involved, one user installed and one from the app.


#7

I don’t know if marksaur ever emailed you, Jesse, but I had the same issue when I had the latest “release” of Source Sans Pro from the Adobe Fonts GitHub page installed:

(At first I had an ancient–2012–version of Source Sans Pro installed, and the “checkbox” icon was a checkmark, and the “checked box” icon was a music note. Very confusing!)


#8

So the latest version from their github page is not working? Where did you get a version that does work?


#9

I figured it out. Anyone still having this issue can install Source Sans Pro from the following link:
https://www.google.com/fonts/download?kit=oSlYq_wYbrV5L-loA5QUynXmVIqD4Rma_X5NukQ7EX0


Unexpected layout for To Do list on initial open of TP3 Preview
#10

Can you tell me what’s different in that link… I’m still not quite sure why this is happening? :smile:


#11

I can’t tell you what the difference is, but I downloaded the latest version of Source Sans Pro from Font Squirrel at http://www.fontsquirrel.com/fonts/source-sans-pro and it did not solve the problem.

The version from Google did solve the problem. The only difference I can tell is that the Google version was a TrueType font (TTF) and the one from Font Squirrel was an Open Type Font (OTF). Could that be it?