Writeroom fails to open RTF document

I have an ongoing document (several years) that I edit and add to in writeroom. the document has always been saved in my iCloud documents for backup purposes. I’ve never had an issue. today, I switched the document to RTF and continued to work, no problem. saved the document and quit writeroom. when I attempt to reopen it (either via finder OR within writeroom) it simply opens a blank page with my theme. the changes ARE saved to the text doc - I can open it in textedit and see that the changes are there. But, I simply cannot open it in writeroom again.

I do not want to copy and paste this 50,000 word document every single time I open writeroom. please tell me what’s going on here / how to fix it! I’ve uninstalled and reinstalled the app, did nothing.

thank you. hoping to find a way to keep using this app instead of going elsewhere.


What happens if you do a “Select All” on that blank page (is there any invisible text to select?)… I’m wondering if maybe the RTF foreground color is set to match the dark background color?

there’s no text. it shoes 0 words, 0 lines on the counters. I can copy and paste directly from the text document and it all ands perfectly formatted. but simply cannot open it.

if I locate the text file in finder and chose ‘open with writeroom’ it opens as a frozen window. I can see the full text but it is not full screen and the program crashes.

I’ve tried a number of different versions of rtf files. it seems writeroom can’t open any of them, even ones that are generated and saved from within WR

What version of WriteRoom are you using? I’m using Version 3.2.1 (112) and RTF files seem to open and save OK for me.

same version. 3.2.1 (112) - no luck. I’ve tried everything. thought it might be that some my theme was the issue, but it doesn’t work even with WR’s default themes. im at a loss

I guess next question is what version of macOS are you using? I’m using 10.15.6.

And just to set expectations… I’m looking here for a workaround. I don’t expect to make any updates version 3.x of WriteRoom. Someday I expect to replace it with a new WriteRoom 4… but that’s still at an undetermined date.

10.15.6 as well. I appreciate your help by the way! would absolutely love to continue using this. it doesn’t seem to be a font issue. I’ve tried multiple themes. even rtf’s created and saved from WR aren’t working. the documents do save and can be opened in other text editors though, just not reopened in WR. what’s your thinking as to what it could be?