Unable to autosave document

I’m getting a message in Bike 1.11 that says “The document could not be autosaved. You don’t have permission to write to the folder that the file is in.” even though I do have permissions, and it was previously saved. It doesn’t matter where I try to save the document, since all locations give the same error. If I try to change the save location, I get a message that says ““[File name]” couldn’t be moved because you don’t have permission to access “iCloud Drive”.”

I tried to work around by copying the contents of the document into a new doc, renaming, and saving, but eventually the auto-save message reappears and I’m then unable to save the document at all.

I’m also seeing this.
Create a new document, save it, then rename the document using the window top bar.
Now trying to save will cause the error.



@timswan @saw Not sure why it would make a difference, but is this with Mac App Store version of Bike or direct download version?

Also can you recreate the problem if you try to save to a location on your drive that isn’t synced to iCloud Drive, or is the problem always related to iCloud Drive?

@jessegrosjean This is on a direct-download version of the app. I can initially save the document to iCloud (or the desktop), but eventually I get the auto-save error, and then I can’t save the file to any location, whether iCloud-based or not. I’ll continue to track what triggers it and will report back.

1 Like

I’m also encountering this, pretty much immediately after updating. Download version - saving to iCloud.

The update reopened all bike docks I had open at time, opened a new dock and Auto-save issue notice appeared soon after. Attempting to manually save stalls bike for a while, then it quietly returns to working.

May not have anything to do with anything, but realized my TextEdit app also stopped responding immediately after (bc switched to it to try to complete the text task).

I mention bc, have noticed the few times Bike mis-behaves it seems my TextEdit does too?!? wondering if there is any shared service (spell check, etc,) contributing to hangs/pause/issues. Probably, nothing - just making stories to fill the gaps … as we do. :wink:

Will try to suss any more behavior relationships if can and update here.

I created a test file and–on creation–saved it to a non-iCloud folder. I worked in the file for an hour and auto-save worked fine. But when I try tom move it to my Desktop folder, which is iCloud synced, I get "“Test bike file” couldn’t be moved because you don’t have permission to access “Desktop”

Could this be a sandboxing issue with iCloud?

I’m using the direct download version and saving to my home folder which shouldn’t be synced with anything. I’m in trial mode at the moment but likely to purchase any minute now :slightly_smiling_face:

1 Like

I expect so, it seems like it must be Sandbox related. How exactly, I don’t know. Also, I’m still not able to reproduce the problem. I’m creating files both in and out of iCloud. Moving them back and forth between. Can’t seem to trigger the issue.

Also generally Bike is doing very little outside the bounds of default Cocoa document based app behavior. Pretty much all the saving code is provided by frameworks.

Can you reproduce same problem by performing same actions in any other sandboxed document based apps?

I’m also using Taskpaper synced to iCloud and Drafts, and neither of those is experiencing issues.

Is it the version of TaskPaper from my website for from the Mac App Store? The version from my website isn’t sandboxed, so I think wouldn’t have the problem… the version from the Mac App Store is sandboxed.

I’m not sure how Drafts is implemented … what if you just try the same actions in TextEdit, does that have trouble or not?

I’m not seeing the issue with TextEdit

Using macOS Monterey 12.6.3 on Mac mini M1, 2020

Hard to say … spell check is a shared service. And if you open the same file in both apps and something goes “wrong” then that can cause a lockup.

If this problem is repeatable you could probably rule out spell check as a problem by turning off all spell check settings in Bike and then see if you can still recreate.

Thanks for trying.

Can you try using Console.app:

  1. Open Console.app (comes with macOS)
  2. In Console app check menu items: Action
    • Include Info Messages
    • Include Debug Messages
  3. In Console.app choose “Start Streaming”
  4. Open Bike and recreate the problem.
  5. Go back to Console.app and choose “Pause Streaming”
  6. In Console.app select all display messages and I think you can just copy/paste them into an email to jesse@hogbaysoftware.com

Now I can’t reproduce the issue! :sweat_smile:

I did quit and restart Bike. Classic turn it off and turn it back on again :slightly_smiling_face:

1 Like

And just as I read your message now I CAN reproduce it… will dig into code and see if I’m being dumb, or Apple frameworks. Yipes, sandbox sure does take a lot of my time over the years.

I think this preview release fixes these problems:

And for the record… problem was in my code this time :frowning:

Thanks @jessegrosjean --seems to be working better now!

1 Like

Thanks @jessegrosjean! Bike is the best … it is the perfect note taker for my daily workflow

1 Like

Yep, looks fixed to me. :+1:
Really enjoying using Bike.
So refreshing to be using a native app and all the MacOS features that brings :partying_face:

1 Like