Trailing whitespace after : makes a line not be a heading


#1

Hey, there - I am noticing that if I have a line that reads (without quotes):

"Topic:"
then is it formatted as a heading. But
"Topic: " is not.

Any chance of ignoring trailing whitespace for this purpose?


#2

I agree that this would be helpful.


#3

I actually love being able to add some trailing whitespace to header-formatted lines to keep them out of the outline, such as when I have a minor list I want to label and make, deep within a project’s hierarchy.


#4

If you add whitespace, then it’s a comment, not a header, and you don’t need the colon in the first place.

I agree that the whitespace should ignored.
And, actually, I think an settings option to strip trailing whitespace would be nice as well.


#5

I don’t expect this to change, it’s been a long time “escape” feature to make a line that visually ends with a colon, but isn’t recognized as a project.


#6

Oh, well. Any chance of a preference to switch between the two behaviors? (Default being the current behavior)


#7

Is there a reason that you need the whitespace there?

I don’t want to automatically strip whitespace on start because some people use it as an escape… and I’d like to avoid adding a preference for this because for now I don’t see the added complexity of adding and explaining a new preference setting is with the benefit.

Would it help if I wrote a script to automatically strip trailing whitespace? I could do that.


#8

Yes, please don’t change this behaviour.
I sometimes import, organise and edit large documents/ebooks in Taskpaper (mostly because I love being able to filter and tag)
The first thing I do is add a trailing space to all lines that end with a colon, that way they don’t falsely get turned into headings.


#9

+1: pls do not change.

I consider this a valuable feature for using a colon without turning the item into a project.