TaskPaper hanging on launch

I’m stumped on this one.

I’ve been using the Setapp version of TaskPaper. Today when I launched it, it immediately hung. No windows, and hovering the toolbar just shows a beachball. I tried launching without restoring windows (open -F -a TaskPaper) to no avail. I tried uninstalling the Setapp version, clearing prefs and saved state, and installing the Paddle version. Same deal. I even tried the preview version with no luck.

Nothing related is coming up in Console. Any tips?

Haven’t seen that.

Not an nvUltra interaction of the kind that Fletcher reported ?

(I don’t have nvUltra here, so can’t test)

Nope, nothing to do with any other app, afaict, just won’t launch at all.

And the file its trying to launch with is not in nvUltra’s store ?

Presumably not locked by an automatic pause in Safari > Develop’s JSContext debugging ?

Definitely not.

It’s not trying to launch with a file. I disabled the restore window when I called it, it should be booting fresh.

Having same exact issue. Have tried installing non-SetApp version and preview versions and same issue.

The Paddle version is working fine (if SetApp is not installed), but I did find that launching it was inhibited when I made a temporary installation of SetApp this afternoon.

(I’m afraid I was discouraged by this event:

and don’t normally have the MacPaw-Setapp software installed now. Kiev is a long way away : -)

Having uninstalled SetApp root-and-branch, the Paddle TaskPaper is working again fine now.

1 Like

A while back, I decided to go with the Mac App Store version, and I couldn’t be happier.

Zero SetApp or Paddle issues. And I don’t have to pay the SetApp monthly rental fee! Hooray! :slight_smile:

Nothing related is coming up in Console. Any tips?

If nothing shows in Console.app, a first guess might be that something in the SetApp installation has started to choke something in the JSContext in which the TaskPaper outline code runs.

Might be worth looking in the Safari JS console after launching TaskPaper with Automatically Show Web Inspector for JSContexts checked in the Safari > Develop > [DeviceName] menu

Incidentally, none of has mentioned macOS version yet.

I am running Paddle TaskPaper here without any problems on Mojave 10.14.6

“Uninstall Setapp” is not a valid option for me. If TaskPaper is going to be available on Setapp, and Setapp is indeed the issue here, then we’d better figure out how to fix it. I completely uninstalled the Setapp version and was unable to launch with a fresh install of the Paddle version. And I do not have either JSContexts option enabled in Safari.

Is this something I should contact Setapp about? I think the onus will be on Jesse to do that if there is indeed an issue with that version or some conflict with Setapp itself. But happy to help if I can.

Regarding the CleanMyMac vulnerabilities, all of those were immediately patched in the next release AFAICT, which was some time ago. MacPaw has earned my trust over the years.

Thanks for all the reports. I’ll look into this tomorrow and see if I can figure out what’s up.

Is this still a problem today? I’m always running SetApp and haven’t noticed any problems. I’m on macOS 10.15.3.

Yesterday after seeing this thread I launched all the different versions of TaskPaper and it was a little hard to tell (my Mac was waiting up from sleep, lots of apps open, and feeling slow generally) … but it did seem that TaskPaper took a long time to open. 2-3 seconds. Then this morning seemed a little slow the first time, but now seems to open instantly.

If you are still seeing this problem can use use Activity Monitor to take a sample of TaskPaper as it tries to launch… or is it not even visible in the activity monitor when you try to launch?

I’ve just email the Setapp people too see if this is something they recognize.

Thanks,
Jesse

I’m using SetApp > TaskPaper on macOS 10.14.6 (18G3020) . TaskPaper has become the backbone of my day to day task management (with some longer term tasks in OmniFocus).

TaskPaper has been working fine. No crashes.

maybe a SetApp setting issue interacting?

Is your SetApp > “Enable Launcher in menu bar” on? Mine is off.

Based on the above, I dare not toggle my SetApp preferences.

update: I went ahead and gave it a try; I put setapp in menu bar. TaskPaper hasn’t crashed. (Setapp 2.5.3)

Same issue still. Currently have the Paddle version trying to launch. Sample: http://ckyp.us/1ggxqK

Please try:

https://www.TaskPaper.com/assets/app/TaskPaper-3.8.10-Preview.dmg

1 Like

Jesse, that works perfectly. Will you be able to apply whatever changed to the Setapp version? Just prefer to get you the recurring income if I can :).

1 Like