TaskPaper 3.8 Update cancelled custom styles


#1

Ever since updating to 3.8 my custom styles don’t work. I’ve opened up Light.less and tried to edit but nothing takes effect after saving, including the older lines the existed before the update.


#2

Can you post your custom style so I can try it out?


#3

Light.less.zip (895 Bytes)

File attached!


#4

Generally your stylesheet is having an effect for me in version 3.8. Can you describe to me a specific styling that you are expecting to see, but not seeing?


#5

Hi Jesse,

Thanks for investigating. The most obvious signs to me that the styles are not being represented are these three items.

  1. Project font size should be bigger
  2. Tasks with the ‘today’ tag should be in red font
  3. Notes should be in a grey font

I’ve attached screenshots of the .less file and my taskpaper window.
20%20PM
03%20PM


#6

Hum… this is what it looks like for me in 3.8:

Are you sure that you are editing the stylesheet that TaskPaper is actually using? If you were updating from an older version of TaskPaper (or switching from Mac App Store version) the location might have changed.

To see the version TaskPaper is using use the menu:

TaskPaper > Window > StyleSheet

A checkmark is next to the selected stylesheet. Also choose the last menu item “Open StyleSheet Folder” to open the folder where your stylesheets are stored. To avoid confusion maybe rename your custom styleshee to a unique name… “my really fancy custom stylesheet” just to make sure that you and TaskPaper are dealing with the same file.


#7

Problem solved! When I checked Taskpaper > Window > Stylesheet there was nothing checked. I honestly didn’t realize that was a selectable list. I thought of it more as a recent files list for some reason.

Thank you!