TaskPaper 3.8.8 crashing on launch on Catalina 10.15.4 beta

Well this is frustrating… I still can’t recreate the problem even when running 10.15.4 Beta (19E224g). I’ve tried in my account, in a guest account, and in a new test user account.

Can you try in your guest account and see if you still get the crash?

Actually… not sure that guest user will do it… unless you remove quarantine flag manually as I described here:

Maybe just try a new user account please, not a guest user.

Thanks, Jesse, that preview version still crashes for me. Crash log attached.

taskpaper 3.8.9 preview crash.txt (90.5 KB)

Do you have access to any other Mac nearby?

I’m at a loss here, not being able to reproduce myself. Things to try different user account on your own computer. Different Mac. If you could get it working in one place maybe be easier to figure out what is different.

I managed to get it working using my wife’s account on my laptop. No idea whatsoever why it’s not working on my account, though…

Any idea what I should look for, next?

Good news!

Randomly I seem to be able to repduce the problem in Xcode now on my own computer. Seem to have found a fix… trying to understand more now:

With luck I’ll post a fixed preview tomorrow.

Well done you! Standing by …

Ok, think I have a fix. Please try:


1 Like

This worked great, thanks…

1 Like