TaskPaper 3.8.8 crashing on launch on Catalina 10.15.4 beta

TaskPaper 3.8.8 is crashing on launch on Catalina 10.15.4 beta.

Do you have SetApp installed?

No, I am not using SetApp. I installed 3.8.8 using the installer downloaded from Hog Bay. Previous versions have been working fine. This is the first version to have problems. It crashes every time I launch it.

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000068

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [2640]

Is anyone else seeing this? I’m not running beta, but can’t see a crash on 10.15.3. I tried creating a new user account and it downloaded and launched Ok there after I OK’d the gatekeeper dialogue.

I tried using guest user account, and it failed to launch there… problem is that I think guest user account can only use apps from Mac App Store. When I manually removed quarantine attributes:

Then TaskPaper worked well from guest account also.

In your account if you go to System Preferences > Security & Privacy > General and look for the section “Allow apps downloaded from” … do you have the second option “App Store and identified developers” selected?

Yes, I do. TaskPaper 3.8.6 worked fine.

Does TaskPaper 3.8.6 still work fine? you can download here:


It does not. TaskPaper 3.8.6 now also crashes on launch. Full crash report for 3.8.6 attached. If I remember correctly, 0x68 was the invalid address in the 3.8.8 crash also.

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000068

taskpaper crash.txt (91.7 KB)

Seemed like the crash was coming from Paddle framework. I’ve just posted a new preview release at that updated to newer version of Paddle.


Can you please try that preview version and let me know if it works for you? Also if you get a crash please attach new log.


Similar issue with the beta and 3.8.8. I’ll be glad to try the 3.8.9 preview.



@psudoc64 Thanks for trying 3.8.9… do you see the link for 3.8.9 in the above post?


I did see the link, and downloaded. First time around, I was still getting the same error(s). I shut down and restarted - that seemed to work and I was able to launch 3.8.9.



Hi Jesse,

I have the same issue; even after downloading 3.8.9 and restarting my mac.

No luck… Any idea which tyres I should kick next?


Can you send full crash log?


Does this work for you?

Yes, thanks. Can you try removing TaskPaper’s Application Support Folder?

  1. Go to menu TaskPaper > Window > StyleSheet > Open StyleSheet Folder
  2. Then close TaskPaper
  3. Show parent of Folder revealed by previous OpenStyleSheet Folder.
  4. Move that parent folder (named TaskPaper) to your Desktop (in case you want to save any themes from it for later)
  5. Once that folder is moved, restart TaskPaper.

Any difference?

Crashes too quickly…

Where would I find it on the filesystem (am very comfortable on the command-line, so POSIX path would be fine)…

Ahh right… that would be a problem :slight_smile:

The folder is:

/Users//Library/Application\ Support/TaskPaper

See if that makes a difference… I notice also that you are running 10.15.4 beta. I guess next step is for me to try the beta. Maybe that’s why I’m not seeing the problem locally because I’m still on 10.15.3


Nope… Moved the whole folder away and is still goes belly-up…

Created a new gist with this crashlog…

Thanks, for help. I’ll try beta.

1 Like