TaskPaper 3.0 Preview (166)


#1
  • Added lead run style for styling task dash.

  • Fix to allow leading task dash color to be styled.

  • Fix to not scroll to last selection when clicking task dash to toggle done.

  • Experiment: In this release if you fully select a line (select entire line including trailing newline) and backspace the line is “removed”, the following line remains at it’s own indent level. Previously the following line would adopt the indent level of the deleted line.

Download TaskPaper 3 Preview


Editing in filtered mode
#2

What’s the syntax for lead? This doesn’t seem to do it.

run[lead] {
color:@tint-color;
}

#3

Works fine for me. So can we get rid of

run[link^="button"] {
    color: @text-color;
}

What will that apply to now, if anything at all?


#4

There we go. Two things wrong. need to get rid of the [link^="button"] AND put it after run[link]


#5

At the moment they should both still match (style) the same, but run[link^="button"] is styling based on an implementation detail might change going forward, while run[lead]] is specifically added for styling. Use it going forward please.


#6

Copy-and-paste behaviors in this release have gotten funky, especially when using TextExpander. For example, I try to expand a snippet at the end of a note, and rather than the snippet expanding my cursor jumps up two lines—and nothing ends up getting pasted in.

Pasting larger chunks from other applications is also causing problems though: when I copy four lines out of a PDF, only two get pasted into my TP document using Command-V—and Command-Z won’t undo the paste job, either.

This may not be new, but it’s the first time I’m noticing it!


#7

I’m not immediately noticing copy/paste problems in my own document.

Few things:

  1. Problems might be cascading… i.e. once one thing goes wrong in the document the following command also won’t work. So need to figure out what the origin problem is.

  2. Are you able to reproduce these problem in the default “Welcome” document? Can you try to create a minimal copy/paste sequence that creates a problem? That would help me track it down and fix it.


#8

Not sure if I’m the only one seeing this as I don’t think anyone else has pointed it out, but as of release 166 I can’t seem to unindent items.

Steps

  1. In a new file, create a new project;
  2. Indent tasks beneath that project;
  3. Press return a couple times to leave some whitespace (whitespace is good you know :slight_smile: )
  4. Create a new project. That remains indented beneath project 1 and there is no way of moving it to it’s own indent. Tried backspace, shift+tab, move branch keyboard shortcuts etc. Here’s a quick demo: http://share.plobo.net/Screen-Recording-2015-12-16-15-33-00/Screen-Recording-2015-12-16-15-33-00.mp4

#9

I tried reproducing your video, but I can’t seem to do it. The big difference between what happens in your video and what I do is that in the navigation tree, your first project becomes the focussed project somehow (it doesn’t happen on mine.) Since that project has now become the focus of the program, the behavior your are mentioning is the right one (you do not want to kick things out of the focussed project.) Try selecting Home and see what I mean.


#10

Good catch @Victor didn’t notice that. I tried once again with a new file and it’s working ok now (as in, not converting the project to a focused project.)

Must’ve been some weird glitch due to a few experiments I was doing.


#11

I think what happened was:

  1. You deleted all projects in your file but one.

  2. You focused that project.

  3. You deleted all visible text.

  4. At this point the project that you had focused stopped being a project (since it didn’t have project syntax, and so it was no longer in the sidebar), but remained a focused item.

  5. Then into that empty screen you typed in some text and the item became a project again (still focused). And focused items can’t have their children un-indented… and so that’s what happened.

Number of odd things in this case. I’m not sure what the best way to fix the UI is.


#12

Well, given that was an extreme edge case because I was mucking around with a script, I?m not entirely sure you’d need to accommodate for it. Then again, I could be wrong.