Script: Archiving @done and logging to Day One


#1

This is packaged as a Keyboard Maestro macro, but the JavaScript for Automation source code is included in the post, and could equally well be launched from Script Editor, LaunchBar, Alfred, FastScripts etc:


#3

This doesn’t seem to work with the new version of Day One, but I think it may be a problem with the CLI rather than the script. I can’t add normal entries via the CLI either. Just a heads-up for anyone who may want to try this.


#4

I’m running it here with the new version of Day One, but you are right that there is a kind of change in the use of the CLI - it now requires the -j switch direct reference to a default folder (which you will see in the .doShellScript part of this script).

I would try to get the CLI running on its own first, at the command line, with small fragments of test text, and perhaps experimenting with that -j switch, particularly if it needs adjustments for a network context etc.

Let me know if it proves obdurate - it may be worth looking at Console.log entries etc

UPDATE: just checked again - still working here with latest versions of everything (TP3, Day One, KM etc)

Probably worth starting here:


#5

UPDATE

You are right - something curious does seem to be happening now. Day One’s own log is reporting an auto import, but the corresponding entry is not showing in my journal …

Perhaps worth pinging them. I’ll do that myself now,


#6

That is exactly what I am seeing. I sent a message to them a few days ago, but they have not yet gotten back to me.


#7

Let’s hope it’s creative isolation – I haven’t had a response either : - )


#8

Me neither :frowning:


#9

My guess is that they are trying to fix it. If that leads nowhere, I’ll look at bypassing the CLI and taking another route into ‘Day Two’

(Brett Terpstra mentions, incidentally, that Auto-Import only works with Day One’s Default Journal at the moment)


#10

Perhaps you got this too today – a message from Day One:

CLI not working is a known issue and we are working on a fix in our next release


#11

I think they’ve just posted a fix for auto-import


#12

Did you get this working? Despite the update, the CLI is still not working for me.


#13

Yes, it’s working here now

I did reinstall the CLI from:

http://help.dayoneapp.com/day-one-tools/
http://dayoneapp.com/downloads/dayone-cli.pkg

and it may be worth refreshing the macro – I have just uploaded my current copy to the end of the original thread (edit rights on the initial post seem to have expired)

( Let me know if still no luck on your system )


#14

Got it working thanks to this:

Thanks!