@pubdate tag does not show up in the sidebar panel


#1

While using @pubdate tag for publication dates I accounted following problem: While being recognized as tag in the main window, the @pubdate tag does not appear on the auto-completion list and in the sidebar panel in the Tags section. I’ve tried some other tag names, but it does not help me to narrow the problem. I think it is a bug in the app (TaskPaper v3.7.4).


#2

It’s showing up for me, did you edit the configuration file as described here:

https://guide.taskpaper.com/using-taskpaper/using-the-sidebar.html

to exclude the tag?


#3

No, I didn’t.

But I noted some strange behavior: If I add a new tag, e.g. @pubdat, then the existing @pubdate (!) tag suddenly appears in the sidebar.


#4

Can you share your TaskPaper document text that’s exhibiting this behavior? On my computer the tag seems to work like any other tag.


#5

Here is a part of the document tested under macOS Sierra v10.12.6 and TaskPaper v3.7.4 (301). No @pubdate tag appears in the sidebar.

test.taskpaper (201 Bytes)


#6

I just tried the file. It works as expected. No unusual behavior.That is strange!


#7

Yes it’s still working for me too. Maybe try a screenshot that shows that test document open in TaskPaper in addition to the sidebar… “maybe” I can spot something odd that way.


#8

Here is the screenshot. I added a couple of @done tags to the test document to ensure that the Tags section in the sidebar is not hidden.

test.taskpaper (237 Bytes)

P.S. Maybe resetting TaskPaper can help. How can I do it?


#9

Before trying to reset, can you try running TaskPaper from your guest user account? Does the tag show up? That account is fully reset each time you are logged out, so it’s a good place to test things like that.


#10

Yes, when I run TaskPaper from the guest user account, everything works as expected :+1:. How can I reset my TaskPaper installation?


#11

Ok, I think the easiest way is to:

  1. TaskPaper Main Menu > WIndow > StyleSheet > Open StyleSheet Folder
  2. Quit TaskPaper
  3. The folder that step 1 opened in the finder is named “StyleSheets”. It’s parent folder is named “TaskPaper”. Delete that TaskPaper folder.
  4. Then start TaskPaper and I think that should do it.

If that doesn’t then try following the instructions here for deleting more files such as preferences, etc:


#12

Thanks @jessegrosjean, I’ll try it.