Print Weirdness


#1

I thought I was being clever. I created a less style sheet just for printed output. It looks good on the screen, all my colored tags are now B&W, etc. All the paragraph spacing looks right.

Can’t hit command P to print but, OK, can pull down print from the menu. But the real weirdness is that the preview in print dialog and the printed result shows the text all light gray and barley readable. No paragraph spacing, no B&W text output and no font size adjustments.

Have I missed something here?


#2

Can you post a screenshot of what your print dialogue sheet looks like and also attach your custom print theme?


#3

Sure.

Code for theme is:

@text-color:  black;
@background-color: white;
@invisibles-color: black;
@selection-color: black;

window {
  appearance: NSAppearanceNameVibrantLight;
}
editor {
  guide-line-color: color: black;
}
item {
  handle-color: gray;
}
item[filtered] {
  handle-color:gray;
}

// Changes the Project Title Font Size.
item[data-type=project] {
  font-size: 12;
  font-style: Bold;
  paragraph-spacing-before: 25;
}
// Changes the Task Font.
item[data-type=task] {
  font-size: 12;
  line-height-multiple: 1.2;
}
// Changes the Note Font.
item[data-type=note] {
  font-size: 12;
  line-height-multiple: 1.1;
}
// Paragraph formatting for the tag "@above".
item[data-above] {
  paragraph-spacing-before: 15;
}
// Paragraph formatting for the tag "@below".
item[data-below] {
  paragraph-spacing-after: 15;
}

Screenshot of print dialog.** Note display on page (left) is correct and print dialog shows text in color (and in larger font).

ADDED: Tried it with and without the added paragraph spacing tags. Samre result. Added a shortened version (of the print.less file) as the main version I am using when I switch to print.less has black background and colored text.

I also just tried it with a completely blank print.less style sheet, same result.


#4

I don’t think it’s causing the underlying problem (see next section), but there’s a syntax error, I think instead you want:

...
editor {
  guide-line-color: black;
}
...

I don’t think you’ve actually selected to use the print stylesheet. You need to:

  1. Click the “Show Details” button in the print dialogue.

  2. In the “TaskPaper” customization section (should be showing first by default I think) make sure that “StyleSheet” is set to “Print.less” (or whatever the name of your print stylesheet is.

  3. Then I think it should work.

What you are seeing I think is the Dark theme in the print preview. By default when printing the background color isn’t included, that’s why it looks a bit odd.


#5

Yes, thanks. That did it.

@jessegrosjean Is there any reason Apples standard option-p reveals a "go to … " instead of bringing the print dialog?


#6

Yea, I got in a hurry, thanks. That was inconsequential (but a good catch). At first I just took my working black theme and changed the light colors to black for the printing. Then, I realized I didn’t really need to do that. :slight_smile:


#7

Command-P is also somewhat of a standard for showing palettes in text editor such as SublimeText and Atom. I feel that it’s more important to dedicate a good shortcut to that then to printing… though of course it’s all changeable through custom keyboard shortcuts if you want.


#8

It is definitely not working for me then. We all have a different workflow. For me it is important to use TP3 for remembering what I have to do and where I am in the process of getting it done. I am old school in that it makes sense to me to print out something I need to keep focused on and carry that around on paper for a day or two. Sometimes I print projects and tape them to my wall to track them.

I love working on my Mac. My computer is a prosthetic brain for my many challenges cognitively. Printing often with a standard Mac print command, is pretty important. I will look at remapping this as I NEVER use the palette in TP3.


#9

Isn’t cmd+shift+p the standard shortcut in sublime text and atom for the command palette ? (just checked and it is…) Cmd+p is for “Go-to” in Sublime Text and “Find File” in Atom.

I’m with @mylevelbest and would prefer to have cmd+p for the print like must native mac applications. As for the command palette, I think it would be best to use the same shortcut as Sublime Text and Atom (cmd+shift+p) or look for what is used in other application (ex: In Vivaldi it’s cmd+e )


#10

Oh sorry, just checked that you mention in TaskPaper that cmd+p is a Go to anything… so yes you’re right about the Sublime Text shortcut. However, I’m used for the print action to be cmd+p. But well, I’ll let you decide what you find it’s best then, since yes I think both could be used…