Pressing the apostrophe/quotes key ( ' / " ) creates a different character in Bike, that Bike will then autocorrect

This seems odd:

If I’m typing Bike will autocorrect things, like if I type “I”:
Screenshot 2023-01-27 at 11.49.38 AM

If I move my cursor there, Bike will say “hey you could mean this instead”:
Screenshot 2023-01-27 at 11.49.54 AM

Then if I use double-quotes:

And cursor over them:

Even though I didn’t never not do well in English class, Bike’s “corrected” quotes look more correct to me, but I don’t know why my keyboard isn’t typing the “more correct” quote in the first place.

Same thing with single apostrophes (is that even what they’re called?):


It’s just not how standard typing at the computer is setup. Keyboards normally type “universal” double quotes. It requires additional processing and complexity to figure out and generate the correct left/right versions, so often it’s easer to just use the universal version that will work for either.

You can learn a bit more about various quote marks here:

When you have the Edit > Checking > Show Checking > Use Smart Quotes option checked then Bike will do that extra processing and replace the universal quotes that your keyboard types with the more typographically correct version.

I hope that answers question.

It does! Amazing, thanks for the info.

If it’s worth anything, I would have never found those extra settings options inside the “show checking” menu if I hadn’t come here and been told explicitly. It’s interesting to me that as a user, I didn’t notice my underlying assumption of “if it’s not found in the settings, it is not behaviour I can change”.

Related, since I haven’t been able to find the shortcuts: when Bike underlines a word, is there any way I can “select” the correction without using my mouse? And when Bike underlines a word, is there a shortcut to “open” the underline without having to move my cursor away-from, and then back-to the underlined word?

For example, I just typed an incorrect word, pressed space, Bike underlines it, if I press backspace I think I’m expecting to see the correction option pop up - but it doesn’t.

Super interesting to learn about universal quotes though!

I maybe should have done it that way, but putting those options in preferences also adds some confusion. The checking settings are document specific… you have have spell check on in one document, off in another. So if you have the settings also showing in system preferences they don’t always match with what you see in a specific document. It makes my head hurt, so that’s why I didn’t do it that way.

Yes, move text caret to the end of the word (using arrow keys) and a popup of replacements should show. Once it’s showing you can press the down arrow to move into the popup of replacements, then use left/right arrow to select the one you want. Then return to accept it.

There’s a blog posted and some demonstration movies here: