Nested Projects don't show up in search


#1

I’ve selected Taskpaper’s option to Add @project tag when archiving @done tasks. But if the archived task belongs to a nested project, clicking on that @project tag will produce a search with no matches.


[ TaskPaper 3.7.5 Preview (305) ]


#2

Editor searches like

@project = "Project / Sub-project"
@project = "Project"

will yield that kind of harvest, I think


#3

I’ve tried using quotes, as you suggested, and it worked.

Why doesn’t the automatically generated search do this? It’s kind of awkward to get zero results when you’ve just clicked a matching task.


#4

A question for Jesse, I think. Perhaps something to do with the spaces flanking the ‘/’ ?


#5

I think this is just something I haven’t got to yet… most of the time tag values are simple and don’t contain any search syntax, but in this case the / is messing things up. I’ll add this to my todo list.


#6

Any update on this topic? I really miss this functionality (for me it’s a bug).
I’ve using the TaskPaper for some projects and I have a lot of task in done. Now, I archived them and guess what: it’s impossible to filter and see the archived tasks per project.


#7

Thanks for reminder. This preview release should address the problem: TaskPaper 3.8.3 Preview (338)