macOS 13.6.3, Bike 1.18.2 - Shortcut Actions missing


I wanted to start using the Today shortcut with Bike but with the given combination of OS and Bike version I’m running into the problem that not all Shortcut Actions seem to be available.
It shows me the error, that “Get Rows” is not available on Mac. I attached a screenshot of the available actions that I can select in Shortcuts.

Quite odd :thinking: Would be interesting to understand why I don’t have that action available.


I’m not sure. I just tried installing the today shortcut from this post:

And it worked using latest Bike preview release 1.18.2 (176). I’m on 14.4.1 (23E224). Though I wouldn’t expect any of those versions to be super essential, since the shortcut was authored and working about a year ago.

What I would do is:

  1. Search your system to make sure that you only have one version of Bike installed and that it’s either the lasts release version or latest preview version. Delete other copies.

  2. Restart Mac and see if that makes a difference.

Please report back and let me know if that resolve problem or not.

No success unfortunately. I rebooted and reinstalled Bike.
I still only see a subset of the Shortcut Actions in the Shortcuts App. Even if I were to rebuild the “Today” Shortcut, I would not be able to, as I don’t have the Get Row Action.

Are you sure you don’t have an old version of Bike installed somewhere on your computer? For example try searching for Bike + Kind Application:

Shortcuts doesn’t necessarily load actions from the version Bike you are currently running. It might be loading from an older version that’s on your disk somewhere.

Anyone else seen anything like this or have an idea of what might be going on?