Losing projects when dragging between documents


#1

I’ve encountered what appears to be a bug that occurs when dragging projects from one document to another. I am running TaskPaper 3.3.1 from the Mac App Store on OS X 10.11.5.

Recipe:

  • Create 2 documents (A and B) each containing a couple of projects and child items
  • Drag a project from document A to document B, from sidebar to sidebar
  • Drag the project from document B back into document A

Expected result:
The final versions of the documents are unchanged, as the project was moved and then put back into document A. The project was added to document B and then removed from document B.

Real result:
The project and children from document A are moved (not copied) to document B on the first drag and drop. When dragged from B to A, the project simply disappears from both documents and cannot be recovered via undo.

Overall, I have found that dragging objects between documents has very uneven - and untrustworthy results. Variations on this recipe will yield different results, all of which may result in a loss of data during drag and drop operations.


#2

I’m not able to recreate this in the default “Welcome” document. Here’s what I’m doing:

  1. Create two new documents with default “Welcome” text content
  2. Drag the “Welcome” project from sidebar A to sidebar B
  3. Drag that same “Welcome” project back from sidebar B to sidebar A

For me (TaskPaper 3.3.1 macOS 10.11.5) this seems to work fine and undo state and behavior seems correct.

This is odd, I think it’s the first that I’ve heard about drag and drop bugs, I don’t “think” it’s a general problem. Few thoughts:

  1. Can you create a simplest case example document and set of instructions that reproduces the problem and post that to this thread.
  2. Does this problem also happen in your Guest user account?

#3

Hi Jesse. Thanks so much for your speedy reply!

I have duplicated this problem on 2 different Macs, each running 10.11.5. One is my 2014 MBP retina, and the other is my old, heavy low-res 2012 MBP.

I have tried this while logged into a Guest account as well - same results.

I observe that if I drag all the projects out of a file, the file becomes empty. When this file is opened in some neutral text reader (e.g., TextWranger) it displays only the text “undefined”.

I am attaching 2 very small files, A.taskpaper and B.taskpaper. These have worked reliably to reproduce this issue.

I made a short movie that illustrates this issue “in action” as well:

I see that this Dropbox link doesn’t play nice with video controls. I hope you can simply download it - about 5.3MB.

B.taskpaper (75 Bytes)
A.taskpaper (75 Bytes)


#4

The movie plays if you get to the context menu and choose “open in new window”. Ah, Dropbox.


#5

Thanks for the video, I am able to reproduce the problem. The difference between what I was doing and what you are doing is that you were selecting the project B2 before moving it. Of course it should work, but that’s the part that I wasn’t doing originally. I’ll see if I can get a quick fix in for this.


#6

I’m glad the video helped. I know that very small bits of interaction changes can make all the difference, and it wouldn’t have occurred to me to say “select the project” as a separate action - I’m blind to all the little things I do so often!

I love the way TaskPaper works, and thanks for what you do.


#7

I’ve just posted a new preview version that I think will fix these issues:

Can you give it a try and let me know if it does?


#8

Just tried preview version 218, and it appears to work just fine. I can drag and drop projects between docs all day long. Thanks for such quick work!

I use this as a way to “carry over” projects from one 2-week period to another. Whatever projects still have undone items get dragged to my next 2-week TaskPaper planner. There’s probably a way to script that, but this method forces me to review what the hell it is I’m doing.