Licence key not working

I’ve been using FoldingText for a week; honestly, its one of the best word processors I’ve ever seen due to its simplicity.
However, after my trial expired today, I tried to activate the licence key (for the 4th time) and was greeted by this message, for the 4th time:

Screenshot 2022-03-19 at 21.37.38

I contacted paddle, and they said that my licence was already activated; however, as far as I can tell, it is not since the message pops up every time I launch the app + I can’t put the app on full screen.

I would really appreciate it if someone could tell me what’s happening

Hi, I’ve sold FoldingText to another developer here:

I think they have a version for download that doesn’t require a license key (they are working on a new 3.0 version).

thanks for the reply; I’ve tried downloading that version but every time I try to launch it this error message comes up from the terminal:

This no longer the site for FoldingText, or FoldingText support – you would need to refer to, and post at: