Laggy UI on MacBook Pro (15-inch, 2016)


#1

Anyone else experiencing this in TaskPaper—running macOS 10.12.2.

Everything across the board has a substantial delay: typing (where the app buffers the entry and then displays it with a big delay), reorganizing list items, autocompleting tags, etc.

Behavior seems to be isolated to TaskPaper.

If you’re seeing it, have any fixes?


Taskpaper freezing while scrolling TP file with 3600 lines
#2

What lauguage are you typing in? There are some known problems with some languages such as discussed here: Debugging NSTextView performance problem when editing multiple languages

Unfortunately I don’t see any fixes on the near horizon. I’ve tracked the problem down into platform code that I’m not able to change. The performance problems that I’m aware of all all related to the amount of text visualy displayed in the text buffer, so you can mitigate most of the problems by focusing into a particular project, instead of viewing all of your projects at once.

Anyway please let me know if that seems like the problem.


#3

I don’t think that’s it. The machine is setup as English as the only language, U.S. region.


#4

Do you have a custom stylesheet … maybe try to disable that? If not that is it possible to take a quick video to show exactly what the problem looks like? You can post it here or just email me at jesse@hogbaysoftware.com.


#5

No custom stylesheet, just running it out of the box. I’ll see if I can video posted this weekend.


#6

Ok, thanks. For what it’s worth it shouldn’t be laggy and doesn’t appear to be laggy when I edit my own lists.


#7

I’ve had the same issue, too, only on my 13-inch 2016 MPB - a 63k / 600 line TaskPaper file occasionally pins the CPU at 100% for a couple of seconds. I haven’t noticed it at all on my 2010 iMac.

It also seems to be totally inconsistent. (Just opened the file on the MPB and it’s working just fine today…)

Ok - I was just able to trigger the high CPU load by moving the TaskPaper window onto my second monitor (an iPad running Duet), with TP in full-screen mode.

Dragged it back onto the 1st monitor (i.e. the laptop screen) and it pegged at 100% / not responding for a bit. Then working normally.

Then putting it into full screen on the laptop monitor pegs it again briefly.

Unplugging the iPad (i.e. switching back to a single monitor config) also pulls TP CPU usage up to 100% but very briefly.

I moved a bunch (maybe 100 lines) of @done tasks into a separate file yesterday to try to fix this but it’s still here.

Hopefully this is helpful – it’s not a huge problem, and the approach of narrowing the view to a specific project as suggested definitely cuts down on the CPU usage.


#8

Isolating to a project relieves the issue for me as well. I checked some smaller files (my example was 60K). Smaller/other files don’t appear to suffer the same issue. I did, simply, make a copy of the problem file via the Finder. Opening that in TaskPaper and the bug goes away when working on the duplicate.

Also running a second screen and can confirm that it’s pegging the CPU in this configuration. The duplicate gets to about 3.3–8.9%

Syncing via Dropbox for use on iOS with Taskmator and/or Editorial.


#9

Here’s a quick/painful video. Pulled up Activity Monitor as well.


#10

Can you send me (jesse@hogbaysoftware.com) that file or some other file that exhibits the same behavior? My biggest test file is 100,000 lines/5mb and it suffers scrolling problems sometimes, but typing performance is still fast and doesn’t peg the CPU.

In the past sometimes the structure of sometimes file has caused edge case problems that I could optimize, some I’m hoping that might be the case here.


#11

I’ve talked a bit more with @spratte and like @derickfay the problem seems linked to the new Mac Book Pro. Performance seems OK in both cases on computers 5 years older. I have a Mac Book Pro (2014, Retina) that also seems to perform fine with TaskPaper.

Is anyone else aware of general Mac Book Pro (2016) performance issues being reported?


#12

It does seem to be unique to TaskPaper - I’ve been using Scrivener, Ulysses, Byword, Microsoft Word, Nisus Writer Pro, TextWrangler among others that redraw the screen without any lag issues. The one thing that is pretty wacked (but I think this is a Sierra problem not a MacBook Pro problem) is PDF editing with Skim and Preview – lots of problems there but TP doesn’t use PDF rendering for text does it?


#13

Ok, good news is I can reproduce the problem now … all I had to do was install and enable https://red-sweater.com/touche/ and then I also see really slow typing performance. That’s good news, I can debug and optimize now.


#14

I think this problem is fixed in this preview release:


#15

I think you’re right Jesse. Just tested it on the old “problem file.” Seemed good in full doc view—no lag.


#16

Well I didn’t set out to test it per se but I used it today for about an hour without noticing any problems so you can call that a successful test :slight_smile: