Italicized note text


#1

When I enter text that’s not a project or task it gets italicized. Can I change this behaviour? I’d rather have my note text be plain by default and not use italics.

thanks
Neil


#2

Yes you can add this rule to your theme:

item[data-type="note"] {
  font-style: normal;
}

More info on editing themes can be found here:

http://guide.taskpaper.com/creating_themes.html


#3

Thanks, that’s great!


#4

I’m sorry to reopen this thread, but I’m not sure I undestand which file is to be modified. With TP 3.3.2, I see style definitions in the following files:

/Applications/Pianificazione/TaskPaper 3.3.2.app/Contents/Resources/base.less

/Users/paolot/Library/Application Support/TaskPaper/Themes/Standard.taskpapertheme

(and other themes in the Application Support subfolders).

Also, the lines posted by Jesse look more like XML than CSS, that I suspect is the code I see in my files.

I can’t understand how to tell TP which stylesheet/theme to select. The old documentation seems to have been entirely replaced by the new one.

Paolo

EDIT: OK, I think I could figure it. The “theme.less” in the Application Support folder will replace the “base.less” inside the application package, only if it is not empty. So, I can simply replace it with my own “theme.less”, and the “base.less” settings are exchanged.