Is anyone seeing the selected stylesheet switching back to "Light.less"

I’ve got a report that every few launches the selected stylesheet switches back to the default “Light.less” stylesheet. Has anyone else noticed this?

1 Like

Not seen here

Not seen on my side as well… Is the user using different stylesheet for different window/document ? (just trying to find ideas…) I’m using only one for all of my documents and never got a problem with that

I see this behavior when I am editing the active stylesheet and save while Taskpaper is open. I have to switch to the stylesheet I’m editing manually every time I save from my external editor, but after that it works fine.

Yes, I’m seeing this in Sierra. I haven’t determined what the trigger is as it’s working properly in El Cap.

Not in 3.5.1 nor in preview, with Mac Os X El Capitan

Yes, almost every time I open TaskPaper. Only with the first file that I open.
I also deleted the old style Light.less from StyleSheet folder, but no result.

TaskPaper 3.5.1 (275) - macOS Sierra

I’m still seeing this.

While troubleshooting, I even deleted Light.less from the StyleSheets directory—and TaskPaper still opens occasionally with Light.less as the StyleSheet.

Using TaskPaper 3.6 on Sierra (10.12.1).

I also occasionally open TaskPaper, and it forgets the last opened document, and it creates a new one with the welcome text in it.

This makes sense… at startup TaskPaper always checks to see if the default “Light.less” stylesheet is in place … if not it copies in a new one. So the part about it reappearing makes sense.

I still can’t see why this would happen… but I normally run with the default them, so haven’t tested. Trying to run with new customized theme now and try over a longer time period to reproduce the problem myself.

1 Like

Again, I’m not sure what to make of this. I’ve been running my version of TaskPaper for last few months with a custom stylesheet and haven’t had it ever switch back to default…

Except sometimes it appears to switch back to default. But in every case that this happens it’s because I’ve launched a different version of TaskPaper. I think maybe this is the issue? There are two versions of TaskPaper, Mac App Store and Direct download. They have different bundle identifiers and so have completely separate preferences, stylesheets, etc.

Normally I use the direct download version, and that’s where I have my custom theme set. But sometimes I’ll accidentally launch the Mac App Store version (which I also have installed) and when I do that it will load up the default stylesheet.

This might also happen if you have an older version of TaskPaper 3 installed. If you are experiencing this problem can you try:

  1. Make sure that you’ve deleted all but on instance of from your computer.
  2. Try to reproduce the problem again

With new release, it seems to be solved. At least on my mac …
(TP 3.6.1 + Sierra)
Thanks Jesse!

Again, damn.
Annoying issue.
I’m trying to to reproduce the problem, but not easy.
Just a couple of clues. It happens:

  1. only when I open the program TaskPaper with a file, and not when I open a file and TP it’s already active.
  2. only with the first file that I open, when I open more files simultaneously.

Sorry, but I didn’t see that this was updated.

I only have one version of TaskPaper installed. That said, after updating to 3.6.1, it seems to always use my custom stylesheet. Hooray!

Before, it would happen one time out of every six launches (or so).

If it comes back, I’ll let you know.

TP 3.7.4 & Mac Sierra 10.12.6 happens every time I open TP. I switch the Stylesheet menu item to my custom stylesheet and everything works as expected with that custom stylesheet selected. Then, if I close out the app and later start it up again, TP goes back to using Light. Happens every time. I only have one on my machine. Really frustrating.

If it’s happening every time that’s actually good news… maybe can get to bottom of this.

The stylesheet setting is saved as a preference. I wonder if maybe there’s something that’s breaking all preference saving in your case.

Can you go into TaskPaper > Preferences, change some of the checkbox settings, and then quite and restart TaskPaper… are those changes that you made to settings saved and restored correctly?

Of course, now that I post about it, it doesn’t happen. Ugh. I de-selected a checkbox in Prefs, then quit and re-started and it remained de-selected. Custom stylesheet was selected as well. Sorry.