Is anyone else seeing a phantom text cursor bug?


#1

Here’s a good movie demonstration:


I don’t think I’ve seen it myself, but in that movie it’s reproducible almost every time.


#2

I was but I think update fixed it.


#3

After a little (overdue) update marathon, I can confirm that this still happens on the latest OS X 10.11.5 with TaskPaper 3.3 (216).

It’s reproducible every time when I click on a different line while the (blinking) cursor is visible. All phantom cursors go away when I move the mouse pointer outside of the document though (didn’t notice that before), so it’s really not that big of a problem.

I have a couple of minor theme customizations, but it happens with the default theme as well. I don’t use any custom scripts.


#4

Can you try running it from your Guest user account just to rule out any other oddities. Also what are your language settings… I have no idea, but maybe a different input manager or something would cause issues?


#5

I’ve tried it from a completely fresh user account, and it also happens there.

Not sure if it matters, but I’m using the built-in trackpad of my MacBook. and I think that I tend to hold the button slightly longer than I would with a mouse.

My system language is set to English with German region/keyboard layout, and I don’t have any Accessibility settings enabled.


#6

Thanks for all the info. I’ll ponder for a while :slight_smile:


#7

This seems to be fixed in version 3.3.2, or maybe an earlier update, but I only just noticed. Thanks! :+1:


#8

I confirm this is happening on my side as well. I was on MacOS 10.11.5 and just updated to 10.11.6 and I still have this bug. It is happening with Taskpaper 3.3.2 and 3.5 Preview (237) (didn’t test the Preview 235 and 236).

I made a video screen capture to show you what it does. I didn’t tried to sync with the blinking, I was just clicking randomly. As you can see, it’s happening almost all the time. The only way to remove the caret is by selecting a line with the “ghost” caret on it (by selecting the line or placing the caret on it – see the video screen capture).

Video screen capture: Click here to view

For the info, I’m using the latest 15" Macbook Pro and with French Canadian language keyboard and using Taskpaper from hog bay software website (not Mac App Store)

If anyone have any idea to fix this bug, please let me know! Taskpaper work great beside this!

Thanks


#9

I can also confirm this is happening on my side with two different Macbooks.
Current one: OS X 10.11.6 (15G31)
Taskpaper Version 3.5 Preview (237)


#10

Likewise – exact same specs.

In fact I can keep clicking new lines and the phantom cursors keep multiplying.

Oh no…the TRIBBLE CURSOR!!!

Wish I had a suggestion, best of luck.


#11

Hi @jessegrosjean, just to let you know that it’s way better with the Preview 260 for this bug. Now, sometimes there’s only a ghost text cursor that stay but only when synchronized with the flashing and it gets away when the mouse move. So it’s way less annoying! Thanks!