Font size intentionally changes with Full Screen toggle?

Not sure if this is by design, or peculiar to my (laptop) hardware, or to macOS, but
Full Screen Mode (^⌘F) is zooming into a larger font size, or at least a larger display.

Can I switch that off ? (I may well have missed a setting, or some earlier discussion)

(For a while I ended up reducing the font size after I entered Full Screen, and then having to enlarge it again after toggling back with Exit Full Screen, but the sudden font size changes do feel a bit uncomfortable to the eyes, and in order to keep the font size stable, I seem to be reverting now to an older macro, which combines HazeOver with a window resize)

It’s expected, but I agree it does need an option.

The conditions are:

  1. You have enabled one of the “Wrap to Column” options
  2. You resize the window larger
  3. After a while (when the margins are getting big) Bike will start to scale up the font to better fill the window area.

This isn’t a fullscreen specific issue, it can also happen if you just resize a window larger.

Option won’t get into current release, but will try to get it into the next set of previews.

1 Like

Got it:

  • I can preserve the font size under Full Screen toggling by choosing View > Text Wrap > Wrap To Window
  • but only at the cost of losing that (c. 25% of screen with) left margin.

No problem – for the moment I’ll use a centred 50% width window with HazeOver.

(and with toggled visibility of the title bar)

(() => {
    "use strict";

    const doc = Application("Bike");

    return doc.exists() ? (
        (doc.showTitleBar = !doc.showTitleBar()) ? (
            "Title bar of front document showing."
        ) : `Title bar of '${}' hidden.`
    ) : "No documents open in Bike.";
1 Like

… and another approach:

Remapping ^⌘F to a script which:

  • Toggles between Normal and Zoomed views, and
  • sets a distinct font size for each.

Here, I’m personally using 12pt for for Zoomed, and otherwise 16pt

BIKE – Toggle Zoomed View (with font size adjustment) (13.3 KB)

Expand disclosure triangle to view JS source
(() => {
    "use strict";

    const usualSize = 16;
    const zoomedSize = 12;

        bike = Application("Bike"),
        w =;

    return w.exists() ? (() => {
        const zoomed = !w.zoomed();

        return (
            bike.fontSize = zoomed
                ? zoomedSize
                : usualSize
            w.document.showTitleBar = !zoomed,
            w.zoomed = zoomed,
            `Bike ${zoomed ? "" : "un"}zoomed.`
    })() : "No windows open in Bike.";
1 Like

The latest Bike preview release adds Settings > Editor > Enable font scaling. Uncheck to disable:

1 Like