Focus


#1

Did some searching in topics, the “may” already be on Jessie’s list, not sure.

I don’t see a way to focus on a task right now and I really wish that I could. Within projects I have several tasks and some tasks have several subsets of things I need to focus on and accomplish. Just now I have to move and that means lots of things that need doing in the next 30 days. Of course, the rest of my life goes on so I am not focusing on that task all the time.

When I do want to focus on the “Move Out” task I have to copy that phrase and paste it into the search bar. There does not seem to be an option in the popup (right clicked) menu to do this. Is there any thought of possibly adding this feature in the future?

Long ago I used Fair Witness/Info Depot. Doing this was one of it’s best features IMHO. Hopping I am not alone in this?

Yes, I could also just place a tag that is unique to each main task grouping and short term, that is exactly what I will do. But, it would be easier if I did not have to enter tags like this. It would be easier if there was a way to (option) click on some task or project and have it become the sole focus.

And, it would be nice if when focusing on a single task (different than using a tag search) what you hoisted to the top auto expanded as well so you could, you know … focus on it.

Using the control key and clicking on the handle I get an option to open in a new window. But each new window keeps the same root name in the menu so it is confusing to remember which window has which focused task in it. If this could use tabs and name the tab by the hoisted item - AND it was smart enough to expand the item then that could work. Would still be good if there was a way to do this without creating more open windows IMHO.
Thanks


#2

I think View > Focus In will do what you want. It works the same as when you select a project in the sidebar, except it works on any item, not just projects.


#3

Yes it does. Thanks. The key shortcut seems to be taken over by my system - it switches screens instead of doing anything in TaskPaper. I will have to sleuth that.

Solved: It was a Keyboard Maestro default setting. Now I can focus in and out with a key stroke, much better.