File Saving Bug in 1.0.1

When editing an OPML file, if I add text to an existing row and Save, Bike touches the file modification date and rewrites the <head>, but the <outline> content is not updated.

Thanks for reporting this.

Can you explain a little more how to reproduce. I’ve tried a few things, but just to make it simple I am:

  1. Creating new outline
  2. Delete all text and replace with single “test” row.
  3. Save using opml format to my desktop
  4. Open that opml file in TextEdit also so that I can see if file changes
  5. Now I make various edits to that first row and all saves appear to update the outline.

And never mind … now I am seeing it. But only when I run release build outside of Xcode. Thanks for catching this… now I’m wondering how this would even be possible! :slight_smile:

I think this is fixed in Bike 1.1 Preview (54). The problem was happening after opening an opml file, then editing, then saving. All my tests were for saving or opening, but not the whole cycle.

The underlying is that internally a Bike row has a set of attributes and a body. OPLM doesn’t have a body, instead it stored text in an attribute. On save I was writing the row body into that attribute, but then I was afterward writing out all the attributes… and overriding the text attribute with old value. Code already had notion of build in attributes that needed to be special cased, but I forgot to add “text” for OPML file format.

Thanks again for finding.

1 Like