‘File has been changed by another application’ error on file save


#1

I’m getting this error whenever I save a TaskPaper document:

image

“The document foobarbaz.taskpaper could not be saved. The file has been changed by another application.”

My file is not located in Dropbox or Google Drive or iCloud, just my ~username folder on my hard drive.

Any ideas?


#2

What is your TaskPaper and macOS version number?


#3

macOS 10.13.3
TaskPaper 3.7.6


#4

Sorry for slow reply… answer is that I don’t really know.

I’m not seeing the issue, and haven’t heard it reported elsewhere recently. It used to be a big problem with TaskPaper 2 on Dropbox… but I don’t think it’s been a problem since.

Does the problem persist through app/system restarts? Also what about if you create and save a new file … does it still happen?

Jesse


#5

I tried to figure out what might be touching the file by creating a new TaskPaper document on the desktop and tracking changes with lsof -r 1 ~/Desktop/test.taskpaper, but nothing was showing up.

However, though I could swear I tried restarting at least once, I’ve just restarted twice in a row and the problem is no longer happening.

I’ll post again if this happens again.

Thank you!


#6

OK, I figured out why this is happening. A web development project I’m working on is using Dinghy, which is a utility for working with Docker on macOS. Apparently, it starts NFS-sharing the home directory when it starts, which is why I’m getting these errors—it’s monitoring/touching every file under ~/user, so whenever I try to save a file, it complains about having been modified elsewhere.

This ‘note on NFS sharing’ explains how to limit the scope of the NFS sharing, which will probably fix this, but I’ve lost a lot of time trying to figure this out and I’m afraid to mess with the setup of this project, so I’ll just leave it for now. I’ll report back if I have anything else to report.


#7

Thanks for all the digging. Is this problem also showing up in other NSDocument based apps? For example do you see the problem when use TextEdit to read/write files.


#8

Yes, it’s happening in other NSDocument-based apps like TextEdit. (see attached image)


#9

Thanks, I think I’ll ignore it then and assume it’s an Apple or Dinghy problem to address.