Dragging and dropping projects in sidebar not working

The drag and drop option for reordering projects in the sidebar doesn’t work properly in my case. When I try to drag and drop a project between two other projects, it always moves to the very top of the project list in the sidebar.

Are others experiencing this issue as well?

Not happening for me.

I have 3.8.12 and it works. What version do you have?

Hm, strange – I have the current version as well (on Catalina).

Just to clarify: I am able to drag and drop a project in the sidebar (it moves away from where it was) – just not to the right place, but to the top of the list.

In case this helps:

Wow, thanks for your efforts! It did help me see that you don’t have the issue that I have – I still can’t explain why I have the issue, though… Your video prompted me to start a new, simple file and try it with that one – interestingly it works with that file. It still doesn’t work with my old one, though. I’ll do a bit more troubleshooting tomorrow and try to find out what the issue is. Thanks again!

Please post if you can share in a simple reproducible file.

Hi Jesse!
I tried to create another file to test it, because I suspected it might be the .txt-file extension I’m using (instead of .taskpaper) – but that wasn’t it.
The file I’m using and have the problem with is my (one and only) task list that I’ve been using for over a year, which is quite full of content. That might connected to why I’m having problems. I haven’t been able to reproduce the problem so far by copying smaller parts out of it. Would it help at all if I sent you the whole file? Wouldn’t want to post it here because it is quite personal.

Yes, you can send it to me at jesse@hogbaysoftware.com. Also please include some 1, 2, 3, style instructions for me to reproduce the problem.


Thanks for sharing… I see the problem, still working on a fix.

The problem is that in your file you have many non-project items at top level (0 tab indentation) indentation mixed in with your top level projects. I think you wouldn’t see problem if all your top level items were projects. With that said TaskPaper “should” be able to handle your case, and I would have thought it already did, but apparently it doesn’t… I’ll try to get a fix out soon.

For example this should reproduce the problem:


And then try to drag a: to after c: and you will see that it instead gets inserted before c:. Anyway thanks for the report and I’ve deleted your file.


Please try this preview release, I think it will fix the problem:


Hi Jesse! You seem to be right with everything you say: The minimal example produces the same issue and the new preview release seems to fix it.
Thanks for this quick fix, that’s great!

Let me just take this opportunity to say that I really appreciate TaskPaper! I’ve tried various task management apps (OmniFocus, Todoist, 2do, Things, etc.), but I was always unhappy with something and finally settled with TaskPaper which so far has met almost all my needs and is beautifully simple. So thanks a lot! (The only issue I have is the missing iOS app – after ditching Taskmator I’m now using Drafts 5 as a workaround, but it’s not ideal. So I hope the future will bring something.)