Date isn't added to @done tag when typing


#1

It is only included when adding the tag by pressing Cmd+D or clicking the dash.

Is this the correct behaviour? I was expecting otherwise, but I’m just getting to know the app, so… ¯\_(ツ)_/¯

Cheers!

[ TaskPaper 3.7.5 Preview (305) ]


Insert Date when using @due
#2

I think you may find what you need in Preferences:


#3

Hi, complexpoint.

Thanks for your reply, but I’m afraid I haven’t made myself clear. That option is checked in my preferences. It’s just that nothing happens when I type the tag. If I click the task or hit cmd+d, it works as expected.


#4

That is by design - a date is added only by the ⌘D toggling command.

( You could set up a Keyboard Maestro (or snippet-expander) macro if you would like dates to be inserted whenever you type that tag in full).


#5

gotta chime in, I share the same sentiments as OP.

the behavior is inconsistent, and I don’t see why the design choice was made to contradict themselves.

I’m sure Jesse has a reason, but it really still should.

(i have the same issue, it’s checked and still doing it, been like that for months)