Crashes in TaskPaper 3.7.2?


#1

I’ve just had a report of frequent crashes on macOS 10.12.5 and TaskPaper 3.7.2… but I can’t seem to reproduce them. Is anyone else seeing frequent crashes on 3.7.2?


#2

No crashes, but the if you do a query and copy the last line of the result, that line is not copied. This happens whether you select all the results or just the last line and it can be very serious if you copy a bunch of text and don’t realize that you are missing the last result.


#3

Thanks, I’ll try to get to this soon.


#4

Hi All - I’ve observed a repeatable crash when trying to Archive @Done tasks using the menu choice. Happens multiple times. - Spinning multicolor wheel appears until I force quite out. Interestingly I WAS able to archive @done tasks using TaskMator iOS App.

Perhaps something is corrupt in the text source file? But then again, I can edit the file just fine, open in text edit, etc. Just has a problem with Archiving.

Thanks,

Karl


#5

Can you share a file where you can reproduce this problem?


#6

Please try this preview release which I think fixes the problem:


#7

Yes, I have regular crashes with 3.7.3 ( since several versions). App just closes. in several situations like closing a tab, changing tab…( not always involving tab though)
Would you need the crash report ?


#8

Yes, can you send me (jesse@hogbaysoftware.com) some crash reports. And ideally describe how to reproduce the problem.

Best would be if you could log into your guest user account. Create a new default “Welcome” document. And then tell me the sequence of steps required to make it crash. If I can reproduce the crash I’m fairly confident that I can fix it, but otherwise it’s unlikely that I can find the cause.


#9

I’ve been experiencing regular crashes for a little while now. Not sure for how long though. I’m on 3.7.3.

The underlying issue might be broader, but, for me, the crashes seem to be always tied to editor searches. Some files don’t seem to trigger this problem, but when I do an editor search on my main notes file (which is my biggest file) and click the “X” to close the search bar, the app crashes. I’m pretty sure this triggers a crash every single time. Interestingly, if I close the search via the menu (View > End Editor Search), it does not immediately crash. But it sometimes crashes later, seemingly for no particular reason.

I’ll send over my crash reports (from ~/Library/Logs/DiagnosticReports, right?).


#10

Please, but more importantly can you send me a file / search combo that will reliably crash. I’m not seeing these crashes… I just created a really big example document and did some searches and canceled them without issue. It’s likely specific to some size/structuring of your file. If I can reproduce it reliably then I can probably fix, otherwise it’s unlikely.


#11

Sure, I just sent the file over email.

Earlier today, I tried reverting to past releases to stop the problem, as I couldn’t really work on the file without it crashing. I first tried v3.7.2, but ran into the same problem. Reverting to v3.6.2 seems to have solved the problem for me.


#12

Thanks, for some reason I couldn’t reproduce this initial, but just did today. The cause seems to be the empty line at the top of your document. Try removing that first empty line and I think the crashes will go away. I’ll release a fix soon.


#13

Here’s the preview which I think addresses this crash. Please try it out and let me know.


#14

Awesome. Thanks so much for your attention to this!