Correct spelling automatically can't be turned off


#1

I have “Check spelling as you type” ticked but “Correct spelling automatically” not ticked in the Preferences. But the latest version of TP3 (166) still automatically corrects supposedly misspelled words.

(i also cannot teach TP3 new words)


#2

I think this is working as it does in TextEdit. The Preferences window setting only applies to newly opened documents. If you want to change the setting in an open document right-click in the text view and set the options from that menu.

This seem to be working for me. To learn a misspelled word I right-click on it and select “Learn Spelling” from the popup menu. I’m on OS X 10.11.


#3

okay, right-clicking on the document window and going to Spelling and Grammar works.

as for “Learn Spelling,” i found that I had to double-click on the word (to select it entirely) and only then does the Learn Spelling right-click menu option appear. I’m also on 10.11.2. That’s fine, but it wasn’t initially obvious.

doug


#4

The “learn spelling” issue here, and the need to double-click to correctly select the whole word before getting the right contextual menu, would appear to be directly related to the issue I raised here: Bug in contextual menu on misspelled words