Click on project results in blank results


#1

Build (154)
I assumed if I click on a project on the left nav bar I would only see that project in the main window. Instead the main window is blank.


#2

You need to indent (using tab) those tasks under the project… and then they will show up I think.


#3

Using a tab worked.
Something for you to consider changing in the future.


#4

I don’t expect that part of the program to change. It’s an outliner, when you click on a project that has no children… no children should be displayed in the editor. I do agree the experience could be made clearer. I might try to add an overlay message in the text view to indicate that the project has no children, but you can start typing to add some.


#5

Bought v3 with great expectations and am totally disappointed.

I used a tab in the above scenario and it worked, but now anything below stays indented. How do I start a new project that is not a child project?

I’m afraid nothing about this is intuitive at all.


#6

“option+return” gets you out of indented items, then “option+command+return” starts a new project :wink:


#7

Please remember this is a preview that I don’t expect to be done for a month or two.

In addition to what @pl_svn says, you can also use Shift-Tab to un-indent. Or the shortcuts in Item > Move > Line Left.


#8

The “intuitive” behavior of how an outliner works is there, but it’s only intuitive if you have used outliners before. There is a common behavior like tab shift/tab for indenting and outdenting. This is true of OmniOutliner, Notebook, TaskPaper, and plethora of others – all going back to much earlier days on the Mac.

You’ll get there! When you do, you’ll likely be amazed at the simplicity for promoting the flow of thought. Have fun!