Can't Paste Can't Link to and launch Local files


#1

I tried pasting some text into TaskPaper 3 and, nothing pasted. I tried the same thing on TaskPaper 2, and Bean and it pasted as it should. I tried recopying from the pasted text in case it was a gremlin text issue but, it seems that TaskPaper 3 will not take pasted input.

I also wrote earlier that TaskPaper 3 will not link to local files. If I drag a local file to a TaskPaper3 document it will leave a file path, but that only opens the folder containing the file. Normal Mac behavior is to click the file link in TaskPaper 3 and the file launches, period. TaskPaper 2 does this.

I know that Jessie recently posted he had some API coding tasks that kept him from making the updates some want and, … please color me, one of those. I paid for the update so I am partially funding this and … c’mon now. It’s still not really usable;e in my workflow. Can’t paste into TaskPaper 3? Can’t embed links to files I need to track working on?

These things are Mac basics, please. Please, pretty please. Can we get this to work again at least to the level that TaskPaper 2 was at? Please?


#2

Is this for any text? For me (in TaskPaper 3 169) pasting text from various sources seems to work.

Hum… I was doing it this way for Mac App Store compatibility. I’m pretty sure when developing FoldingText it was the case that Mac App Store apps could not open files directly… instead they had to just open the folder and present the file to the user.

It seems this might have changed… anyway I’ll change the behavior back to just opening the file for now (will be in next release). We’ll see what happens once it’s time to submit to app store.

Anyway thanks for your support. Please let me know more about pasting… seems to work for me. File path opening is changed for next release.


#3

Sure, thanks for steering me to the right place to post. :wink: TaskPaper 2 uses the active file path to open the file. I know this also works in Bean, Mail and most Mac apps that I have tried it on. Not in nvALT unfortunately. For this user, I absolutely must have this feature. I use an app like TaskPaper to track projects and when I have to take extra steps, added to the level of distraction I already suffer, it’s just not going to work.

I hope the app store doesn’t become your new focus? That is up to you and you have every right to make as much as you can by distributing your very nice apps as widely as you can. I can respect that, but I cannot support it. I have still not purchased even one app from the app store as I strongly dislike Apple asserting their control that strongly in my computer using experience. Some will agree with me, some wont. I try not to judge, but I will vote with my dollars.

As far as the paste goes, I just made up a TaskPaper 2 document with a few headings and sub text. I copied some of it and opened a taskpaper 3 document. Then I pasted. And … The top heading line pasted and … nothing else happened.

I ran your updated patch this afternoon, same results.


#4

No, it is the only way that I distribute the current released versions of my apps, but with TaskPaper 3 I’m going back to also distributing it myself using Paddle as my payment processor. With that said I also generally try to write my code so that I can continue to sell the same app on the Mac store too with minimal changes.

I don’t doubt there’s some bug, but I still can’t reproduce it. I just tried:

  1. Open TaskPaper 2.
  2. Create a new document (automatically filled with default intro text)
  3. Select all and copy that text.
  4. Open TaskPaper 3
  5. Create new document.
  6. Select all
  7. Paste

For me that sequence seems to work fine. The text from the TaskPaper 2 intro document replaces the text from the TaskPaper 3 intro document.


#5

Hmmm … I just tried the same thing.

  1. Open a new document in TaskPaper2 (created boilerplate)
  2. Select all
  3. Copy
  4. Open Taskpaper3
  5. Paste
  6. Result “Welcome”, and nothing else.

If you want me to try anything, let me know.


#6

Do you have any plugin or custom theme?

I guess few things to look for:

  1. Make sure TaskPaper 3 about panel says Version 3.0 (169)
  2. Make sure you’ve removed any custom themes and scripts.
  3. If problem persists:
  • Open Window > Script Debugger
  • Select the “Debugger” pane.
  • In the left pane click the light blue colored breakpoint symbol to the right of “All Exception”. It should become a solid blue color once clicked. Then try pasting. Does the app freeze… because the debugger stopped on a breakpoint?

#7
  1. Version 3.0 Preview (169)
  2. No way I can tell about custom themes in version 3? It’s not mentioned in preferences anywhere?
  3. Followed your instructions and no, it did not freeze when I pasted. It didn’t paste anything either.

#8

Unless you’ve “worked” to create a custom theme you don’t have one… shouldn’t have caused a problem in the first place anyway, just reaching for ideas :smile:

Does anyone else have an idea here? Does paste work/not work for anyone else? I’m out of ideas at moment.


#9

Nah, thanks. I played with themes in the version 2 of TaskPaper. Haven’t messed with it at all inversion 3. I saw in the help files that it is in the user.less, but that was my first time opening it.

I opened an early version of a TaskPaper 3 document that I had typed some info into. In that document, I can paste after the entries.

This seems to be somehow related to starting a new blank document. There seems to be some confusion on my part about whether the project button opens the project bar or not? By this I mean that, until I have a heading, the Project bar does not appear to open? Or, is it already open and just a blank project bar? Maybe that is why it wont paste?

I can also tell the blank document to create a new task or project, and it still wont accept a paste command.

I am also seeing, in the new document that wont accept a paste command, it seems to ignore a line ending in a colon. And, it wont create a new line with return key, unless I also hit the option key. It just is not behaving as TaskPaper should, for some reason, in a new blank document.

This all goes away of course, once I open a pre-filled in document I made in TaskPaper 2 and then add to it in TaskPaper 4 (including pastes)

Once I get a document that has some text in it, I can fill in by pasting new text. But not until it has already started. Now at least this is a work around. Useful once the version that has file launching again in the links.