Can't open files because of "untrusted author"


#1

Hello,

Why mac os does not recognize task paper as trusted author?

I am constantly getting these kind of messages: https://cl.ly/0c2L1u3B0x10 (polish language)

It says that mac os in unable to open document because it comes from untrusted author.

What’s going on?


#2

Is it possible to temporarily switch your language settings to english so that I can see the exact english text of the dialogue? I’m quite sure it’s a general macOS issue, not TaskPaper specific.


#3

Here is a translation:

“It’s not possible to open „maj-2017” because this software comes from unidentified author
Your security preferences allow to install programs from App store and from identified authors only.”

2 cents from me:
maj-2017 is a simple txt file and I set a txt files to be opened by default by task paper previously.


#4

Sorry I’m not sure on fix, but I’m pretty sure it’s not a TaskPaper specific issue. Have you tried google searching the error message, I bet you could find more on how to fix from that.


#5

I think I’ve run into that problem before — or something very similar. Have you tried right-clicking on the file and using the context menu to open it? In my experience, it will then tell you that it’s from an unrecognized author and are you sure you want to open it, and you tell it yes. Once it has permission to open the file, it should do so without any grief.

Not sure how exactly it happened in my situation, so I have no idea if that will work for you, but I hope it helps.


#6

It should be a setting in your Security and privacy setting in System preference.
If you go in System preferences > Security and privacy > General and you unlock the preference (click on the lock on the left bottom and enter your password), you can select a different security option in the "Allow apps downloaded from"
I have it set to “Mac Apps and identified developers”.
If I can’t open an app and I get that error message, I can go to this Security and Privacy setting and allow that particular app only to be opened.
Hope this helps,
Antonella


#7

your solution works only once (in a current mac session) and yes - I tried it before


#8

I see. My experience is similar to what esotaria describes: you give permission the first time you open the file and then it works from there.