Bike shortcuts not present in Shortcuts app

Hello! I bought a license today and installed Bike 1.12. I was interested in using Bike’s shortcuts, but when I open the Shortcuts app, Bike is absent from the apps listing.

I’m still using Monterey, but I didn’t think Shortcuts were affected by stuff like that.

Any ideas?

Bike sadly missing from Shortcut's app listing

I’m not sure. I just setup a test account here and:

  1. Deleted all local copies of Bike
  2. Verified that Bike wasn’t showing up in Shortcuts
  3. Downloaded Bike.dmg
  4. Copied Bike to my Desktop
  5. Reopened Shortcuts, and Bike was listed

So I’m pretty sure it can be made to work, there’s nothing “really” broken! :slight_smile: This is on macOS 13.4.

A few thoughts:

  • Make sure to copy Bike from the DMG onto your Desktop or /Applications folder. I have no idea if this makes a difference, but sometimes I think (maybe only in old days) macOS has a harder time finding/indexing apps if they are copied to other locations at start

  • Maybe try an OS restart. I do remember reports of people trying to use Shortcuts with various apps… and apps don’t show up. And then mysteriously after a while they do.

  • You could also try downloading Bike 1.11 and see if that works. I don’t have macOS 12 to test on, but I’m pretty sure some macOS 12 users were using actions on 1.11. It’s possible I made some change in 1.12 that broke things on older macOS, though I don’t think I changed much of that code.

  • Let me know how it goes!

Hey, I just tried all three options (and I saw spotlight just re-indexed), and still no Bike in Shortcuts! Baffling.

Ah, sorry for wasting your time. I just did more digging and realized that Bike’s shortcuts are only on macOS 13.0 and above. It’s true shortcuts can run on earlier versions of macOS, but the particular technology that Bike is using to implement shortcuts requires macOS 13. Sorry for not remembering this sooner.

1 Like

Added to the list of things slowly pushing me to upgrading from Monterey. Thanks for the help.

1 Like

I occur same issue, I think is because App Store version conflict with Website version.

  1. Install Bike from app store
  2. now, shortcuts has bike action
  3. open Bike website version
  4. bike action in shortcuts hidden
  5. reinstall bike from app store and shortcuts action show again
1 Like

Thanks for the report and series of steps to fix. I don’t think there’s a change that I can make to Bike to work around this problem, but good to know how to work around it outside of Bike code.