Bike quite unexpectedly

Hi Bike support team. I purchased the app last week but I only started using the it today and, unfortunately, the experience wasn’t as pleasant as I hoped for. I have tried three times and it alway crashes for me after 5-10 mins of using it for no obvious reason. Attached is the problem report. Please advise what the problem is and how to resolve it. Thanks.

bike-crash-report.txt (49.7 KB)

Can you tell what version of macOS you are using and what input manager? Crash looks like it’s happening in text input, maybe using an input manager that isn’t well supported by Bike.

The report says macOS 14.1.1 (23B81).

1 Like

Looks like it may be one of the non-standard Chinese IMEs

( Bike is working well here with Apple’s own Chinese IMEs, for example Pinyin Simplified and Pinyin Traditional )

The report says macOS 14.1.1 (23B81).

Thanks! (dumb Jesse!)

@tamakisquare If you are using Boshiamy input manager there were some problems with that a while back: Boshiamy text input problems. I thought I fixed crashing issues, but maybe there are others.

It would be helpful to know:

  1. Input manager settings that you are using
  2. If problem goes away if you use another input manager such as ones suggested by @complexpoint

(Though FWIW for Traditional characters, IMEs like Apple’s implementations of Cangjie and Zhuyin etc, which also seem to be working well here with Bike, may be more relevant).

1 Like

That’s weird then. The only Chinese IME that I have installed on my system is Apple’s implementation of Traditional Chinese Zhuyin (see attached image). In addition to that, the only other IME I have on the system is Apple’s English, Canadian.

@complexpoint - could you confirm that you have tried Bike with Apple’s Traditional Chinese Zhuyin IME and haven’t had any issues with it?

Zhuyin is not an IME that I personally use, but I have installed it and tried typing a few paras – no problems so far, but I’ll harvest a system log if anything does show up.

Bike 1.18.1 Preview (170)
Sonoma 14.3.1