App crashes when "with " inserted in line of text that has existing "with"

Occurs in current version and one prior to 1/25/2023 1.8.1 (98) update.

Problem: App crashes when inserting the word "with " in a line of text that already has word “with” in it.

Replicate: Crash Occurs when

  • inserting the word ‘with’ between beginning of a line and another existing instance of the word “with”
  • when you press spacebar after typing the last letter ‘t’

Sometime the crash reporter occurs and allows App restart, sometimes not.

Example: In the 2 lines below, adding the word ‘with’ at any point prior to existing “with” later in line causes crash

  • Coordinated with Mark on Team meeting
  • Created 12pm team meeting: invite to Bob and Alice (to share with Company Staff)

Thanks for reporting this.

Am I doing this right? I start with:

Coordinated with Mark on Team meeting

And then type with at the start of the line to end with:

with Coordinated with Mark on Team meeting

But so far I’m not seeing any crashes.

What version of macOS are you using? Also what are your Edit > Checking > Show Checking settings? Right now I have all settings checked.

Not yet managing to reproduce that here, either.

(macOS 11.7.3 )
(Bike 1.8.1 (98))

Is it possible that any kind of expansion (triggered by wit|h) etc is set up by anything else installed on your system ?

1 Like

Shoot was hoping it was easily reproducible and not just me.
Just tested and it’s not a unique event to one of my own documents.
Happens on your default Welcome to Bike! opening page, too.

My Checking settings are

Specs again are:
(MacOS 12.6.2 - MacBookPro: 14-inch, 2021, Apple M1 Pro, 16 GB )
(Bike 1.8.1 (98) )

Do you have anything related – e.g. starting with wit – set as a Text Replacement under:

System Preferences > Keyboard > Text

(or the equivalent for your version of macOS)


and if you temporarily disable Use text replacements under Checking, do you still see this problem ?

1 Like

I tried those settings and still couldn’t reproduce on macOS 12.3.

I think @complexpoint is right, next most likely possibility is Text Replacement… easiest if you can just send screenshot of your whole list of text replacements from system settings.

Also if you can send along one of the crash logs from crash reporter that would be helpful too.

AHA! :raised_hands: :raised_hands:

Bike’s Use text replacement is the inflection point. When its turned off - doesn’t happen!

But I’m not doing any wit replacement in my Sys Prefs. Screenshot and Crash log from test attached

Screen Shot 2023-01-27 at 12.07.55 PM

Bike Crash Log 2023-01-27 12-09-06.8841 -0500.txt (32.0 KB)

1 Like

Perhaps try just eliminating that ththe rewrite ?

(in case it’s firing while you type with)


Thanks, that’s the issue. I just recreated the crash by adding that completion. I’ll also try to fix in Bike’s end.


Yup, that was it. Huzzah!!! Now removed … Certainly don’t need the th replacement - I don’t remember even adding it … clearly a lazy hack for bad typing habits

Bizarre! Thanks all for the help with hunt and fix. Just curious was this a Bike coding logic issue or just an edge case collision with Bike and Apple text management functions?

1 Like

Please try this Bike Preview release. I think it should fix that crash. Hopefully without causing any new ones!

1 Like

Seems to have fixed it. :+1:

Running preview with my Keyboard System Pref text replacement “th → the” back in place and withed like no tomorrow:

  • with with with with with with with with with asdfasdf with

Many Thanks Jesse, complex point!
May the force be with with you.

1 Like