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Welcome
WriteRoom is a full screen writing environment. Unlike the cluttered word processors 
you're used to, WriteRoom lets you focus on writing.

Why WriteRoom?
We created WriteRoom as an alternative to Microsoft Word. WriteRoom’s full screen 
writing environment gets your computer out of the way so that you can focus on your 
work. The result is a subtle clearing of the mind that we think helps you write better.

WriteRoom won't do page layout or insert tables and graphs. WriteRoom's focus is just 
to help you get words on the page. Stay focused with WriteRoom's distraction free 
environment. Stay on track with word count. Stay safe with autosave.

What's New?
Built for OS X Lion
WriteRoom's been rewritten to support OS X Lion. Full screen, scrollbars, autosave, 
and auto-resume are all what you expect from a native Lion app.

Preferences Out, Themes In
We’ve removed WriteRoom’s old preferences window and replaced it with a themes 
solution that’s inspired by the new OS X Lion auto-resume behavior. Now, just change 
your setting’s on the fly in the current document and they will be remembered. For 
example, enable spell checking through the Edit menu... and now it will be enabled for 
the current document, and in any new documents that you create. It works the same 
for fonts, colors, and everything else.

To make this new behavior more flexible we’ve added themes (See the Window menu > 
Themes) that store your settings. You can create multiple themes and quickly switch 
between them, and even share your themes with other users. For example you might 
have a “First Draft” theme that has all spelling and grammar checking options off. And 
you might have a “Final Draft” theme that has those options on. You can also create a 
full screen variant (with a dark background color maybe) that will automatically be used 
when entering full screen mode. 

In the switch to themes we’ve also taken the opportunity to add a bunch of long 
requested options. You can now set background images/textures, and you can even 
choose typing sounds. See the menu Window > Themes > Edit Edit Current Theme.

And themes are sharable. Choose the menu Window > Themes > Open Themes Folder 
and then you can share your theme with others.



Track Your Writing Progress
WriteRoom adds optional session tracking and logging (See the File > Session menu). 
Session tracking allows you to see how long you’ve been working and how much 
you’ve written in that time. Check the View > Show Statistics > Session Count & Time) 
menu item to display. Session logging saves that information (and more) to a 
spreadsheet file so that you can track it longer term.

Working with WriteRoom
Rich Text or Plain Text documents?
Rich text documents (*.rtf) are great for when you need formatting such as bold, italic, 
multiple fonts, colors, sizes and so on. When you change these in a rich text 
document, these changes are written directly into your document’s *.rtf file. 
WriteRoom’s themes try to leave as much of the original formatting in place. When 
using rich text documents, changing themes will not permanently change your 
document’s formatting, font, font size, text alignment or text color unless you 
change it yourself. If a theme uses text scaling, the font size will look larger or smaller 
but the original font size is not affected. In WriteRoom 3.2+, the text will use the 
theme’s color for display only, which can be overridden from the View menu.

Plain text documents (*.txt) are flexible, widely compatible, and let themes change how 
the text looks without needing to worry about incidental changes to your document. 
With plain text, the content stays the same and how the text appears depends on the 
text editor itself. When using plain text files, changing themes changes the entire 
appearance of the text seamlessly, but the document may have the same 
formatting when you open the file in another text editor like TextEdit.app.



WriteRoom Menus
In most ways WriteRoom should work just like the standard TextEdit application that 
ships with Mac OS X. In the following sections, we’ll focus on where the menu 
commands are different.

File menu

• New: Creates a new plain text document 
(*.txt, untitled, unsaved).

• New Rich Text: Creates a new rich text 
document (*.rtf, untitled, unsaved).

Open New Windows submenu

• Full Screen Single Mode: WriteRoom's 
'classic' full screen mode, this blanks out 
your desktop so you can focus on your 
words. It only affects a single desktop 
space or monitor. Move your mouse to 
the top of the screen to show the menu 
bar.

• Full Screen Mode: Lion-style full screen 
mode, WriteRoom is given its own full screen desktop space. Move your mouse to 
the top of the screen to show the menu bar.

• Standard Mode: This is window mode, which behaves like any other Finder or 
application window.

• Begin New Session: Starts tracking the word count and time spent in a new writing 
session. To show live session info check the menu item View > Show Statistics > 
Session Count & Time. A new session is automatically started when you open and 
begin editing your document.

• Record Sessions in Spreadsheet: When checked, WriteRoom will automatically 
keep a record of your writing sessions in a spreadsheet file. 

• Reveal Sessions Spreadsheet in Finder…: Use this menu item to open the 
Sessions folder (~/Library/Application Support/WriteRoom/Sessions) so you can view 
and use the data from your writing sessions. Session data is saved into a single *.csv 
file per document name. You can view *.csv files in most spreadsheet apps and even 
with QuickLook.

• Tip: To use OS X's QuickLook feature, click on a session’s file once, then press 
space. 



Edit menu 
Selection submenu

• Use the commands in this menu (or better yet, 
memorize the handy keyboard shortcuts) to 
easily select the current word, sentence, or 
paragraph. 

Structure submenu 

• Use the commands in this menu to shift lines 
about with ease. You can indent, de-dent, shift 
up, and shift down multiple lines at once. 

Format menu
Line wrap submenu

• Column 40 ~ 200: Select to wrap your text to a specific 
column width.

• Column Window Width: Select this to wrap the text to 
the window size, not to pre-set columns.

• Wrap to Page: Select this to wrap to the standard 
printed-page outline.

• Make Rich Text/Make Plain Text: Swaps between editing 
and saving your document as rich text (*.rtf) and plain text 
(*.txt). Rich text format allows you to have different fonts in the same document. If 
you don’t need that we’d recommend using the Plain Text format as it’s simpler and 
more portable.



View menu
Scale submenu

Sets the amount of text scaling for the theme. Text 
scaling does not modify the document or theme’s 
original font size, which lets you enlarge or shrink 
apparent text size without changing how it appears in 
other themes or in other applications.

Show Statistics submenu

Check the items in this menu that you’d like to see in 
updated live as you edit your document.

• Counts: Displays count for entire 
document, and if you’ve selected some text 
displays separate count for the text you’ve 
selected.

• Reading Time: Displays a rough estimate 
of the time it would take to read your 
document.

• Session Count & Time: Displays how long 
you’ve been working and how many words you’ve typed in the current session.

• Fade Full Screen Stats When Typing: Enable this if you don't want to see your 
writing stats all the time when in full screen mode. To see them again move your 
mouse.

• Typewriter Scrolling: Enable this to keep your text cursor in the middle of the screen 
when typing so you're not writing at the bottom of your screen!

• Blink Insertion Point: Feel free to turn this off if a blinking cursor is a source of 
distraction or anxiety!

• Always Show Scroller: Enable this if you want to always keep an eye on the scroll 
bar. Disable it and it'll fade away.

• Highlight Current Line: Enable this to show a subtle highlighting bar across the 
current line, so you always know where you're typing at a glance.

• Tint Selection & Cursor: Enable this to tint your cursor and selected text the same 
colors as your theme.



• Use Block Insertion Point: Makes the normal "thin" insertion point into a retro-style 
"fat" insertion block.

• Show Invisible Characters: Shows and hides paragraph, space, and other invisible 
characters if you need them for editing.

• View in Original Color: (Rich text documents only) When enabled, your rich text 
documents will display with their actual color instead of the theme’s text color. When 
disabled, the theme’s text color will override the document’s set text color for display 
only. The theme’s text color is not saved to your document unless you manually 
change it from the color palette.

Window menu

Themes submenu

• Theme Selection: 
Use this list to 
select another 
theme. You can also 
use the keyboard 
shortcuts to quickly 
switch to another favorite theme.

• Create New Theme…: Select this to 
start a new theme file. All theme 
changes are automatically saved to 
the currently active theme, so if you 
want to try something new it's a 
good idea to create a new theme file 
first!

• Create/Delete Full Screen Variant: 
If you want to use a different theme 
in full screen mode than in window 
mode, Create a full screen variant 
from here. If you want to use the same theme for both, Delete the variant from 
here!

• Edit Current Theme Colors & Images…: Select this to show the Theme Editor 
window (for everything except fonts!) From here, you can edit text colors, 
background and page colors, set images for backgrounds and page textures, and 
set typing sounds if that's your thing.



• Open Themes Folder…: Opens the themes folder (~/Library/Application Support/
WriteRoom/Themes) so you can copy, delete, or rename theme files.

• Enter Full Screen Single: Go into "classic" WriteRoom full screen mode. This blanks 
out the desktop, but lets you use multiple monitors and utility apps in the same 
desktop space (such as the nifty Marked.app for Markdown previews.) 

• Enter Full Screen: Go into Lion-style full screen mode. WriteRoom will get its own 
desktop space, and other monitors will be blanked out with Lion's "linen" 
background texture.

Working with Themes
Setting up your WriteRoom theme got a complete overhaul from how it was handled in 
previous versions. Now you can store and use multiple themes, and even share them 
as a WriteRoom theme file.

Create a new theme
• Go to Window menu > 

Themes > Create New 
Theme… and then give 
your new theme a 
memorable title.

• Press command+t or go 
to Format menu > Font > 
Show Font. Select your 
favorite font and size.

• Press command+shift+e 
or go to Window menu > 
Themes > Edit Current 
Theme Colors & Images. 
Enjoy!

Modify the current theme
• Just start making 

changes! Any changes to 
font, color, background/
page images, or writing 
sounds are saved 
automatically.

http://markedapp.com/
http://markedapp.com/


Use a different theme for full screen mode
• Go to Window menu > Themes > Create Full Screen Variant

• When you’re in full screen mode, any changes you make to the theme won’t affect 
the theme in window mode.

Modify a different theme
• Since all changes are saved to the current theme, make sure to switch to the theme 

you want to edit before you start making changes!

• Window menu > Themes > (select the theme you want here) 

Share your themes
• To install a shared theme, double-click on its icon in Finder.

• To share a theme you really like, open the Themes folder and copy the theme file you 
want to where you want to share it (email, Dropbox, CloudApp or your favorite 
method).



Support Notes
Tips & Tricks

• When you are writing, select a word, and then press Command+Control+D to 
bring up dictionary, thesaurus, and Wikipedia for the selection.

• When you enter your license information (if you downloaded WriteRoom from our 
website, not the Mac App Store), be careful to copy the email contents exactly. 
The two most common errors during registration are entering the User Name 
differently (mixed case, punctuation, or middle initials) and copying over an 
incomplete License Key. You can re-send your website license from here.

• If you have multiple documents open in Full Screen Mode, you can cycle 
between them using the command-` keyboard shortcut, or press your hotkey for 
“Application Windows” as set in System Preferences > Mission Control and 
select from the list at the bottom of the screen.

• To ensure that your plain text files work well with other apps, such as WriteRoom 
for iPad, iPhone, and iPod touch, save them using UTF-8 Encoding. This can be 
done using the save dialog (‘Save…’ or ‘Save As…’) or in Preferences (General 
tab: Document Encoding).

• QuickCursor for Mac brings WriteRoom to any app with a global keyboard 
shortcut. Unlike manually copying and pasting between apps, QuickCursor 
automates the entire process to save you time.

• If you’re not sure where a particular command is located, click on the Help menu 
or press Command+Shift+? and type in the command you’re looking for. With 
the mouse or arrow keys, select the item from the search list; the menu will open 
and an arrow will helpfully point to the command. This works in most OS X apps, 
too!

Running AppleScripts
WriteRoom includes some basic support for AppleScripts. Your scripts can be 
accessed from a global OS X menu or with a keyboard shortcut:

• To activate the global AppleScript menu, open AppleScript Editor.app, open 
Preferences and select the ‘General’ tab. Check the option ‘Show script menu in 
menu bar’ and look for a new script icon on the right-hand side of your menu 
bar.

• To add a script to the OS X script menu choose Script Menu > Open Scripts 
Folder and place your script there. You can also place scripts in a subfolder if 
you wish.

http://www.hogbaysoftware.com/store/resend_licenses
http://www.hogbaysoftware.com/store/resend_licenses
http://itunes.apple.com/us/app/writeroom/id288751446?mt=8
http://itunes.apple.com/us/app/writeroom/id288751446?mt=8
http://itunes.apple.com/us/app/writeroom/id288751446?mt=8
http://itunes.apple.com/us/app/writeroom/id288751446?mt=8
https://www.hogbaysoftware.com/products/quickcursor
https://www.hogbaysoftware.com/products/quickcursor


• Use System Preferences > Keyboard & Mouse > Keyboard Shortcuts to assign a 
keyboard shortcut to your script (you may need to add it as a Service first), or 
use a utility like FastScripts.

User Support/Forums
• WriteRoom Support Forums: http://groups.google.com/group/writeroomapp

• WriteRoom Wiki: http://www.hogbaysoftware.com/wiki/WriteRoom

• WriteRoom Themes: http://blog.hogbaysoftware.com/tagged/writeroomtheme

• WriteRoom Product Page: http://www.hogbaysoftware.com/products/writeroom

• Hog Bay Software Support Page: http://www.hogbaysoftware.com/support

Thanks and Credits
Embedded fonts
The following fonts are embedded for use in WriteRoom 3.0 thanks to free licensing or 
the kind permission of their designers. Where applicable, their respective licenses are 
included in the application bundle in /Applications/WriteRoom.app/Contents/
Resources/EmbeddedFonts/

• Bitstream Vera (via its generous 2003 copyright which allows redistribution and 
bundling with software in this manner) 

• Glass TTY VT220 (via its public license and kind permission)

• Inconsolata (via SIL Open Font License version 1.1)

• Ubuntu (via Ubuntu Font License version 1.0)

http://www.red-sweater.com/fastscripts/
http://www.red-sweater.com/fastscripts/
http://groups.google.com/group/writeroomapp
http://groups.google.com/group/writeroomapp
http://www.hogbaysoftware.com/wiki/WriteRoom
http://www.hogbaysoftware.com/wiki/WriteRoom
http://blog.hogbaysoftware.com/tagged/writeroomtheme
http://blog.hogbaysoftware.com/tagged/writeroomtheme
http://www.hogbaysoftware.com/products/writeroom
http://www.hogbaysoftware.com/products/writeroom
http://www.hogbaysoftware.com/support
http://www.hogbaysoftware.com/support

