Wrong behavior with Text Expansion: does not delete all characters


#1

FoldingText (FT) is the only soft showing this behavior: when I use an abbreviation created with DashExpander (a text expansion app), FT will only delete the last letter of the abbreviation used, and not all the code.

Example: when I type “&ht”, I obtain “http://www.” everywhere, except in FT where I get “&hhttp://www.”: only the last letter “t” has been deleted, “&h” remains at the beginning.

Rem: I have not tested with other text expansion softwares (e.g.: TextExpander, TypeIt4Me, Typinator, …)

It’s not a blocking problem (I’ve bought FT knowingly), but it would be nice if a solution could be found: I use these abbreviations a lot.

Thanks!


#2

FoldingText’s text input system is rather different then most OS X text editor. Long story, but the editor is build in JavaScript using the CodeMirror library. And it gets it’s text input from a hidden text field… result is that utilities like this can have trouble.

But FoldingText does support OS X text replacements. So for example (assuming you haven’t changed your defaults) if you type omw followed by Tab then that text will expand to “On my way!”. You can learn a bit more about it in the User’s guide “Text Replacements” section.


#3

I had imagined it could be something like that but, as PopClip works perfectly in FT, I had not abandoned all hope for a solution.

Thanks for the suggestion of the text replacement feature of OSX: I had never really tried it and didn’t know it could be so powerful. My first test shows it should replace DashExpander for a big part (even multilines snippets are accepted, I’ll miss placeholders though).

Best!


#4

Just a heads up Jesse, but as of version 2.0.2 text replacements seems to be broken. I have a few custom replacements that I had previously setup and they are no longer working.