Unable to insert special characters (Yosemite)


#1

Hi there,

I am having trouble inserting special characters into a document. Not sure if it’s related, but I am running Yosemite.

It seems like an issue with the window interaction. When I do CTRL+CMD+SPACE, the special characters window appears, but not at the location of my cursor.

Here’s a short video demonstrating the problem:

I am able to copy/paste these characters into the document.

In the video, I am selecting emoji, but the same thing happens for any special character (e.g. non-emoji like the ™ symbol or similar).

Does anyone else have this problem?

Thanks,
Dan.


#2

When I do CTRL+CMD+SPACE I get a different looking special characters pallet that looks like this:

And double-clicking does seem to insert the special character. Do you change some default setting to get that newer looking special character pallet? I’m also using OS X 10.10.


#3

One can toggle between those two pallets (in 10.10) by clicking the little icon at the top-right hand corner:


#4

And I notice that character insertion works fine if we summon that pallet from the OS X input method menu rather than from Edit > Special Characters


#5

I have this same problem, it’d be nice if this flow just worked like it does in other system text fields.