Typing accents or CJK in Roman text lines -- strange behavior


#1

Hi,

I am writing a lot of CJK words Western text.

When I type Western text, then change to CJK (Kotoeri or so) text input, start typing the cursor jumps several characters back to the left, the text I type and the Western text already typed cover each other. When I hit enter and the final text version appears, the text looks OK, and there are no problems with the output.

When I wright pure Japanese, no such problems occur.

But when I type an accent in a Western text, there is as similar behavior: e.g. “`” which shows code. These characters have a similar “intermediate state” before they are set – like writing in CJK. The jump to the left as well before I hit enter and everything looks good.

Best,
ms


#2

I’m not sure that I understand what is happening, can you make a quick screencast of the problem and share that too? Thanks!


#3

Thanks for looking into it. ScreenFlow.mp4.zip.ft (1011.7 KB) The video is in a .zip file, just delete the .ft.

Thanks!


#4

Sorry can you email me (jesse@hogbaysoftware.com) that video directly. I think it didn’t complete uploading or something, because when I click on the link I just get a “not found” error. Thanks!


#5

Hello,
I sent you the video immediatly. Maybe everything is fine, but since I got no reply, I wonder whether you got the small video? Thank you.


#6

Thanks for the reminder… I did get message, but it had been filtered to my “Support Forum Alterts” folder… and since I keep track of all of that on the forum anyway… I never read it.

Anyway, I see the problem now in the video, but I can’t seem to reproduce it myself. Can you tell me what version of OS X you are using? Also if you have any custom themes, plugins, etc… can you try out FoldingText in your guest user account and see if you can reproduce the error there?

Thanks.


#7

I just tested Folding text on another computer without my customizations. The problems are the same. Here is my set up:

Mac OS 10.8.3, German with at least kotoeri (Japanese) active in addition, Japanese keyboards with US layout for Western script, which I change to German in the language preferences. Additionally, I have set the keychain such that ctrl-[letter] gives ā, ī, ū, ē, ō, ŏ, ŭ and ĀĪŪĒŌŎŪ repectively.

This setup is the same on all my computers, there is no problem of this kind with any other software, small text writing apps included.

Cheers and thanks.


#8

I expect the problem is that you are using 10.8 and I’m using 10.9. Unfortunately I don’t have any copy of 10.8 to test/debug on. Do you have any access to a 10.9 computer that you could test on just to verify that this difference is the cause of the problem?


#9

Maybe it is the system. I do not have 10.9 running on any of my systems any more, and I am not planning to change this in the near future. It was a horrible mess in the beginning with CJK scripts, just not worth it.

Just an aside, Apple’s frequent system updates create a persistent situation of apps running well and apps not working any more. After 23 year with Mac I am preparing a change to Linux and full OpenSource with software that proved to “just work”. FoldingText was just too nice not to use during the one or two years left. So I will use it with the CJK glitch for the time being with Apple.