Turn Off Automatic Link Identification?


#1

Is there a way to tell TaskPaper not to automatically identify links? I’m constantly having bogus links execute when I’m trying to edit the text that’s been identified as such. Also, half the time the automatic link is wrong because the real link contains a space.

Thanks.


#2

There isn’t a setting for this right now. Can you post some examples of problematic links and non-links?


#3

Sure. An example is “/Users/username/Library/Autosave Information”.

First, TaskPaper creates a bogus link of “/Users/username/Library/Autosave”, stopping at the space.

Second, if I want to edit this, it takes some mouse acrobatics to keep TaskPaper from accidentally executing it.

Third, this is just a path I want to include in my notes–I’m not interested in creating a link in the first place.

Thanks.

Bob


#4

Ok, I was thinking web style links, so glad I asked.

To escape spaces in file paths you need to proceed the space with a \. Note that if you drag and drop a file path into your document TaskPaper will automatically insert those escapes as needed.

For positioning the caret in a link you can hold down the option key while clicking. Then the caret will be put inside the link without activating it.


#5

Ah, of course. I’m still not sure if that’s ideal for me. It’s great for executing directly and pasting into a command line, but it doesn’t work for pasting into a dialog window (e.g. BBEdit open file by name). And sometimes I’m just trying to save info in human-readable format about a path somewhere else. But I see the logic in why you set it up the way you did. And I have the sense that once I get used to it I’ll likely grow to love it. :slight_smile:

The bigger issue for me was being able to place the caret, and the option key solution completely takes care of that.

Thanks.