TP 3.3.2 is not remembering recent documents consistently


#1

On two different macs, both running El Cap 10.11.6 , TaskPaper’s Open Recent… menu item isn’t working consistently.

I just opened TP. The only file it showed in Open Recent… was one I hadn’t touched in weeks. I then opened a file that I had worked on last week (but which didn’t appear in Open Recent… ). Now Open Recent… shows that file plus 5-6 others that should have been there when I first opened TP.

I don’t know if this an artifact of running TaskPaper 2 and 3 concurrently – that was my first suspicion but the recent lists in each are completely different.

Anyway it’s happening sporadically on two Macs, and has been for months (mentioned in passing here: Editing themes -> TP 3 window and app switching issues )

I don’t have issues with Open Recent… with any other apps on either Mac.


#2

Just happened again – TP had been getting recent document right for a while (week+?) on my laptop then I rebooted, and now TP only shows one recent document, which I haven’t touched in a few weeks, and none of the ones I had open yesterday.


#3

I don’t have any great ideas on this.

TaskPaper 2 and TaskPaper 3 use different bundle identifiers… I think most everything is keyed of that, so I wouldn’t “expect” running them at the same time to be a problem. Unfortunately I can’t think of anywhere in my code where I deal with recent documents (all “for free” behavior provide by the cocoa frameworks). If you can find a specific reproducible case I’ll look into this, but other then that I don’t really know where to start.


#4

Yeah, it’s not TP2/3 b/c I realize now that it just happened on a laptop on which I no longer have TP2 installed. I’ve heard of cases where it happens across the board but it’s definitely only in TP3. I’ll see if I can come up with a reproducible case. Thanks.


#5

Same issue here… Can’t remember the last time this worked, but I think it used to.


#6

I’ve just been messing around in both 3.3 and the 3.5 beta and I can’t seem to reproduce the problem. The most recent document that I’ve edited also seems to bubble to top of that menu. Seems to maintain the state through restarts of the app.


#7

@derickfay @macula Have you noticed if this is still a problem in the last two 3.5 preview releases?


#8

Hmmm I saw it again today on my laptop with 3.3.2 - let me upgrade to the latest and see.

update 4:17 PM: opened 3.3.2 on the laptop and the file I opened this morning is there, but none of the others from previous days that I’d also expect to be there.

4:20 PM: installed 3.5 (260) and there are no recents. Exited and quit and now the files I opened are in the recents.

So…so far so good!


#9

Glad to hear, @derickfay and @jessegrosjean. I am currently traveling abroad and, for the first time in more than a decade, without my laptop. (My first experiment with iPad-only travel, by the way.) So I will not be able to test this before the last week of September. Sorry!