Todo Mode Doesn't Work


#1

I tried creating a todo list, but the list items only show up as bullet items. I named the file 0-To Do.todo, but it just doesn’t behave according to the documentation. Can you help me?

Regards,

Geoff Odhner


#2

I think you might have misinterpret the documentation here.
Lets try this :
Create a file named as you see fit with the extension that suits your needs (I use .md).
Then, in that file, type a first line of text and end it with .todo.
Start the following lines with a dash+space (standard Markdown list item AND standard TaskPaper task)
Example :

tasks to complete.todo

- task 1
- task 2

Note, if your list_header.todo is also a Markdown header (i.e. starts with #), then every - task hierarchically below it will behave the same, displaying a checkbox (until it hits a new header of the same level or greater, but without the .todo ending).

Not 2 : you can apply a @done tag (and strike the text) to any line of text, regardless of it being a task or not.

Does it help ?