Todo completion shows wrong character when click box


#1

It is usually very satisfying to click a todo checkbox except that it should convert the box into a checkmark not a quote character when the todo is completed. I am using FoldingText 2.1 (753).

BTW:
I also get a checkbox character error when using TaskPaper 3 except that when I add a todo it has a checkmark instead of a checkbox when it is entered and changes to a musical note when it is clicked. I am using Taskpaper Version 3.0 Preview (156).
http://www.glensharp.com/images/glensharp.com/images/Voila_Capture2015-11-16_09-54-03_AM.jpg

Any idea what could be causing this?
Is it unique to my system or is it a bug in FoldingText and TaskPaper?


#2

It’s a conflict between font’s embedded in TaskPaper and FoldingText and a font with the same name installed on your system. I think if you disable the “SourceSansPro” (for TaskPaper) and “SourceCodePro” (for FoldingText) fonts on your system (and restart apps) then it should go away. Or another option is to update those fonts to match the same version of the font that’s include in TaskPaper and FoldingText.


#4

Jesse,
Thanks so much for identifying the fonts that I need to sync to solve the problem. That saved me a lot of time. I have temporarily deleted my versions of the fonts and that did fix the problem.

However I do want to have these fonts installed for use with other programs. Could you identify your source and version number so I can make sure they match? Was your source Github as that is where I am planning to get the latest version unless you have a better alternative.
Thanks again!
Glen


#5

I think the versions from Google Fonts are working.

Source Code Pro is here:
https://www.google.com/fonts/download?kit=5CnRSlG29fo96WRM6evqx_Al0-Z8Vhl9gBgy16Ux03q3RwK3DjTwCNxYbmVP1-YA96xlbbE5D7Gw2o7jubnkMA

Source Sans Pro is here:
https://www.google.com/fonts/download?kit=5CnRSlG29fo96WRM6evqx_Al0-Z8Vhl9gBgy16Ux03q3RwK3DjTwCNxYbmVP1-YA96xlbbE5D7Gw2o7jubnkMA


#6

just updated to 2.1.1 which is supposed to cure this — no change.
guess i’ll have to go for the font synch solution, which is a bad hack, since those fonts can be/are used elsewhere


#7

this was really bumming me out, but i replaced the version of source code pro on my system with the google fonts versions that @walton posted and it works! you guys have made my day, thanks!


#8

Updating to Google Fonts version works! Thanks so much. Was bumming me out too.