Taskpaper continues to ask me to activate license


#1

I purchased a license to TaskPaper 3 in Nov of 2015, but recently I’ve noticed that I must re-enter my license information each time I open the app. I just tried this with versions 3.6, 3.6.2, and the 3.7 preview, all with the same result. The issue occurred on Mac OS 10.11.6 and 10.12.3.

Any help would be appreciated. Please let me know if you need any additional information.


#2

When you enter your license does it accept it… i.e. does it allow you to use TaskPaper after entering it?

Are you ever running any of the TaskPaper “Preview” releases?


#3

Yes, it does accept my license each time and I am able to edit TaskPaper documents like normal.

I believe I ran the preview/pre-release for version 3, which I purchased in November of 2015. I also tried the 3.7 preview to see if this would resolve my error. I believe the 3.7 preview is currently the version I have installed.

One additional piece of info: I tried to remove any support files associated with TaskPaper but I couldn’t find any in ~/Library or /Library.


#4

I can’t seem to reproduce it at the moment, but I know in the past there was a problem where TaskPaper would ask for your license key again each time you switch between launching the preview and non preview versions. Can you try:

  1. Launch TaskPaper by double-clicking app icon in the Finder (to make sure that you are launching the exact same version each time)

  2. Enter license key. Quit

  3. Launch again by double-clicking the same exact app icon in the Finder…

Does it ask you for license key that second time?


#5

Sorry for the delay. Following the steps in your last message seems to have worked – the app is not asking for a license now. Maybe I was switching between the preview and non-preview versions accidentally.

I appreciate the help and responsiveness! TaskPaper (and Folding Text) is some of my favorite software.