Drag-and-Droppy


#1

Hi,

This is a maiden post. I love FT - see my glowing review in the app store.

Here’s the bug which is worrying me most: When I select some text and try to move it using drag-and-drop with the 3-finger gesture on the trackpad, the whole text moves, not just the selected text and the result is unpredictable - see screen shot.

I’m surprised that no-one else has picked this up because there’s nothing strange about my configuration.

Regards,

Alfabeck


#3

This is a bug. Drag and drop of selected text is meant to be supported, but right now there’s that visual artifact when you do a drag and drop operation. Few things to note:

  1. This should only be a visual issue, drag and drop function should still work.

  2. Oddly this problem only shows up where there’s not a lot of text displayed on the screen. If you have a long document that’s not all folded up then you shouldn’t see this visual artifact.

This is definitely on my bug list, but since it’s cosmetic and most people don’t seem to use the feature anyway I haven’t dug too deep for a fix yet.


#4

Thanks. Knowing that, I can live with cut-and-paste.

While I’m at it, here are a few other things I’d like to bring up:

  • I’m having trouble understanding Command Mode: it doesn’t seem to work in the way described in the User’s Guide. After opening Command Mode I only get a list of plugin commands and can’t enter any other command.
  • In the Edit/Copy menu item, Copy is greyed out when there is nothing selected but this is not the case with CopyHTML or CopyRTF. Shouldn’t the appearance of all three be the same because their behaviour is the same?
  • I sometimes put FT files at various places on the desktop. However when FT saves them, e.g. automatically, it sometimes moves the document icon to the top right hand corner of the desktop.
  • When I press the option key while the cursor is over a link or ## etc. in order to place the cursor there, I’d like to see the cursor change to a vertical bar rather than continuing to be a hand.
  • When a new line is created in the middle of a numbered list, the new item automatically gets the correct number. But all those following it are wrong by 1 and have to be corrected manually. What am I missing?

Thanks for the excellent support!


Update cursor based on Option key state
#5

This is fixed for next release.


#6

I’m tracking that issue here: