Default file extension


#1

how can you change the default file extension again?
i’m pretty sure the terminal command was mentioned somewhere in the old forums, but i can’t find it anymore and i’m back to .ft after the 2.0 update : (


#2

You can set a different default style extension with the defaults key DefaultFileExtension.


#3

that i found, but i don’t understand what it means. :confused:


#4

You need to open “Terminal” app paste in something like this:

defaults write com.foldingtext.paddle.FoldingText DefaultFileExtension newextension

That’s setting a user default for the application with the identifier: com.foldingtext.paddle.FoldingText. If you have the Mac App Store version installed then you would change that part to com.foldingtext.FoldingText.


#5

thank you, just did that (without the $).


#6

I’m just removed the $ to avoid conduction. Normally that’s an indicator that you are typing at the terminal prompt.


#7

This is no longer working for me. Strangely it worked the first time I used the command. Then I rebooted the comp. Now no matter what I do, .ft will not allow me to change the default file extension to .md. There is no save as option either.

Help!


#8

Hi there,

Any help/suggestion with my issue with DefaultFileExtension command above still now allowing me to set a different file extension when saving a file would be great. Currently when I try to save a new file with the extension .md, it just stubbornly refuses to and keeps adding the .ft to the filename.


#9

Forgetting about “DefaultFileExtension” for a moment, you should always be able to force your own extension by unchecking the “If no extension is proved, use …” option box in the Save dialogue.

Now if you are trying to override “DefaultFileExtension” one thing to be aware of is that the version download from my site and the version downloaded from the Mac App Store have different identifiers. So you might have to adjust the line above to include the right identifier:

com.foldingtext.FoldingText (to effect Mac App Store version)
com.foldingtext.paddle.FoldingText (to effect download from my site version)

Another thing to be aware of (I just ran into problem myself) is that previously I released the “com.foldingtext.paddle.FoldingText” version as a sandboxed app. But now it’s released as a non sandboxed app… and that means the preferences are located in a different place.

Unfortunately it seems that as long as the sandboxed version of the preferences file exists, then the defaults write com.foldingtext.paddle.FoldingText command targets that version instead of the nonsandboxed version of the preferences. All very confusing…

But end result is I think it will work if you first delete ~/Library/Containers/com.foldingtext.FoldingText. Then try that terminal command again.


#10

Well, I downloaded the app from the app store. And I don’t see the com.foldingtext.paddle.Foldingtext in my Containers.

I did remove the Containers folder as you mentioned. Started FT and ran the command. No luck. Removed again. Ran the command, started FT. No dice.

So I guess something else if preventing me from getting this to work.

Should I uninstall the application and install again?


Saving new file from window title doesn't respect defaults
#11

Also… perhaps in a future version, you could give the user the control over which extension to choose by default. .md is now a pretty standard extension for markdown files. This will really help when sharing files with others, or say opening the file on another device, iPad and such, which doesn’t have FT.


#12

I am using version 3.0 preview. Is there anyway to stop Taskpaper appending a .taskpaper extension to the file? I would like to use a basic .txt file extension. When I manually override the default by typing into the rename dialogue, the app automatically appends .taskpaper.

Thanks for anyones help.


#13

I need to add a setting for this, but currently no there isn’t.

You can workaround the problem by creating a .txt file outside TaskPaper… once you’ve created it you can open/save it in TaskPaper without the file extension changing.


#14

A small request: any chance you could get FoldingText to still display the FoldingText file icon on files after the default file type has been switched?

I use .txt as my default file type (for compatibility reasons) with FoldingText assigned as the default app, and all my .txt files are blank white rectangles. I’d love to see the foldingtext file icon instead. Put another way, I’m fine with manually switching default file type, but it would be great having foldingtext still put its icon on whatever file types is assigned as its default.


#15

Hi Jesse, I’m using .txt extension to sync with Ulysses. What are the differences between the txt and takpaper format? just extension?


#16

Sorry for slow reply… yes it’s just the file extension.