Collapse all by level: not working in one file

I have a large projects file with many nested projects. All projects are unfolded. Now I position the cursor on a top level project and hit successively “Shift + Cmd + 9” (which will trigger the menu “Collapse all by level”). Normally this would collapse the leafes of the outline successively, every time I hit that key combination, until my outline is completely collapsed.

This worked every time I used it, and it still works in all my other project files, but not in the large one anymore.

I checked my projects file with other text editors. All indents are tabs. So correctly formated.

Does anybody have an explanation why I cannot use that command in this particular file anymore?


To be more specific: Items up to level 3 are successively folded by successive hits of the key combination. But then folding stops there.

See screenshot:

Not sure if this is relevant here, but one source of confusion can be that the TaskPaper format is a purely tab-indented outline.

In the following example, Beta, Gamma and Delta are not children of Alpha (they are peers), and will not be collapsed under it:

- Beta
- Gamma
- Delta

(only tab-indented items are children of preceding project lines. If the project is itself indented, only items that are more indented descend from it)

See the example at:

In your example above, it looks as if DONE Mig etc is not indented under - Decide ...,

(not sure if that reflects the structure you want)

Thanks for the reply.

My indents are all tabs. But as you can see in the screenshot below, my projects have children, not siblings, and the children won’t get collapsed until level 3.

So I position the cursor on the project “Mig to DEVONthink”, and hit “Shift + Cmd + 9”, but nothing happens.


I wonder if any of the tabs are preceded by space characters ? I notice that the degree of indentation in the GOAL, Mig, Leave sequence is visually fractionally deeper than that in the Listen Verbliebene Loesche sequence.


Opened the file in VS Code editor, searched for a tab preceded by space, could not find any entry.

But your observation solved the problem. Deleted the extra tab in front of the children of the project “DONE Mig Things3…”, and now everything works fine.

Thank you very much. Never would have found that one. :slight_smile: